FANDOM


Bugs:Edit

Death of Fanari prevents quest from initiating I was 90%+ finished with all of the DLC content but still never had this quest and was unable to get it to initiate. So I was trying to figure out where I had gone wrong, as Baldor and Deor were both still alive and always in the Skaal Village but no matter how long I waited, nobody every had the quest-trigger conversation and there were no dialog options--with ANYONE--regarding it. I did recall, however, that I wasn't expecting the Lurker to appear and attack so at least one Skaal NPC was killed by it after using Bend Will on the Wind Stone. So I had to go all the way back to a save point before Cleansing the Stones and ensure that none of the NPCs at the Wind Stone were killed by the Lurker. After I spoke to Storn once the Wind Stone and the villagers were freed, I went back to Raven Rock, waited a few in-game days, then fast-traveled back to Skaal. Almost immediately (and directly in front of the fast-travel arrival point) Fanari Strong-Voice and Deor began talking about Baldor which, afterward, initiated the Misc. quest objective of talking to Deor.  Once I finally got the achievement for smithing a Stalhrim item and returned to where I left off, I went and double-checked and one of the NPCs killed had been Fanari. So anybody else who has had issues with the quest being broken may want to check their game to see if it could be because Fanari Strong-Voice had died, also.  13thDoctor (talk) 06:52, December 8, 2012 (UTC)

No quest triggerEdit

-I have no clue why the quest isn't triggering for me. Fanari is alive, no one died in the Wind Stone Cleansing, and I waited about an in-game week afterwards in Raven Rock before returning to the Skaal Village, and Baldor was still there and, of course, Fanari and Deor never initiated the quest conversation. By that point I said "screw it" and went on with the next story quest that supposedly "prevents A New Source of Stalhrim from being completed" for some reason (I see no reason why; the Shaman has no connection to the quest and no one really hates you after his death..)--Mazekial (talk) 21:09, December 9, 2012 (UTC)

Okay, now that is interesting... because I did have one other variable which could have contributed the "Quest not initiating (original play-through)" and the "Quest *did* initiate (after loading an old save in which I had to go through everything again, staring with the entire Temple of Miraak quest)."   But it seemed unlikely. I only knew that two villagers had died--not which ones, specifically--and I had just assumed one of them was Fanari that first time. But before I was able to get the quest to initate, I had tried loading a save from immediately after finishing the Temple of Miraak but before Cleansing the Stones... nobody was killed that time and I still never got the quest... but I'm not sure if I waited long enough for it, either.  But now here's my question for you, Mazekial: Did you, by any chance, already have the "Abandoned Lodge" location discovered before the Cleansing the Stones quest? In my original playthrough (and save-game I used in my second attempt), I already had discovered the Abandonded Lodge... and that location is one of the locations used in the quest. My reasoning, here,  was that having it already discovered before that quest somehow prevents the quest's initilizations from loading there correctly, like the Thalmor NPCs and the stuff around and inside the building), (some sort of conflict erorrs, perhaps?) and because of that, the quest never initializes. If this does turn out to the case for you--where you had been to the Abandonded Lodge first---then it may be worth putting this idea to a more "controlled" test to see if that is actually the determining variable...? 13thDoctor (talk) 21:44, December 9, 2012 (UTC)
Ok, now that I finally got time to play Skyrim again, to answer your question no, I had not discovered that location. HOWEVER, I did uncover a/the proper way to trigger the quest. While doing some quests in Raven Rock, I asked the bartender at the Retching Netch for rumors, and he described how the Skaal's smith has gone missing and the Skall have told them to keep an eye out. I travel to the Skall Village after this and the quest started as normal. We should probably add this in in case anyone else is having trouble starting the quest.--Mazekial (talk) 00:56, December 15, 2012 (UTC)
Well I've tried initiating the quest by talking to the bartender at the Retching Netch, but I'm not having any luck. Every time I ask him if he's heard any rumors, he says that he hasn't heard anything recently and says to check back later. I've tried waiting several in-game days while inside the Netch, outside the Netch, inside the player house in Raven Rock, in Skyrim, etc., but every time I come back, he doesn't have anything new. I'm pretty sure I've finished all of the Dragonborn quests (aside from "A New Source of Stalhrim," the quest that you get from the other guy in Skall once you finish that quest, and the never-ending radient quests, obviously.) Not sure what else to try... 13thDoctor (talk) 00:13, December 28, 2012 (UTC)

Still aliveEdit

This is really annoying me, I travel to Skaal village and the two people aren't talking about his disserperence because the blacksmiths is still here, how do I activate this quest if the blacksmith hasn't been kidnapped, I've completed the main storyline and loads of side missions, Bethsada, please patch this so it's actually playable. 217.155.197.130 19:39, December 12, 2012 (UTC)

Rumors to trigger the questEdit

Is there asking about rumors at the Retching Netch a surefire way around overhearing the conversation in the village? Because when I cleansed the Wind Stone Wood-cutter was killed by the lurker and I didn't re-load a save. I have sinced finished the main quest storyline and don't have any saves before cleansing the stones. Am I completely locked out of the quest now?98.25.44.243 23:26, February 23, 2013 (UTC)

Trouble withEdit

If anyone is having trouble because one of the required NPC's died during the cleansing, it is possible to bring them back even if their body has disappeared.  Simply using resurrect with the appropriate reference id won't work.  You'll have to load up a save in which that NPC is still alive.  Walk up to them and open the console command box, then select the character, this will tag that NPC's reference id.  Close the console box and load up your more current save where that character has died.  Open the console command box and you should still see the ref id selected at the top.  Simply type resurrect 1 and voila! Your NPC should be alive and well in your current save.  Be sure to give them a minute to walk up to village from the Wind Stone.-micnet 75.224.175.63 02:25, March 3, 2013 (UTC)

I have had the same problem in that I think both Fanari and Deor are dead. The problem is, I do not have a save to load which will bring them back to life. However, I do hope that Bethesda maybe does another update on Skyrim which allows the quest to be activated anyway. If you open the console and type "help deor 4" or "help fanari 4" you can get the NPC reference codes if they've died. You can then use "player.placeatme reference_code" to spawn a new Deor or Fanari. Might be worth trying this and then using the "setstage" fix mentioned in the bugs section.
Do you Guys tryed to talk to the Blacksmith in Raven Rock ? After I Talked to him and he told me about Stahlrim I was finally able to find Fanari and Deor talking to each other about the missing Blacksmith ! :D 37.24.152.154 19:46, September 18, 2014 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.