FANDOM


Follow-up questEdit

- follow up quest should be Liberation of Skyrim not Reunification of Skyrim. —This unsigned comment is by Ja50nX (talkcontribs) . Please sign your posts with ~~~~!

Actually, both quests are follow ups as this quest is given by both the Stormcloaks and the Legion. I agree with Brumisator that there should be two pages for this quest, one for both factions. Aleksandr the Great (talk) 23:20, December 6, 2011 (UTC)

Bugs (PS3)Edit

- after the Jarl of Whiterun surrenders i am told to tell Ulfrich of our victory & although he has the quest marker above him i have no dialog option available to do this. Have tried going through all other speech options, pickpocteting & getting caught, attacking & even going werewolf but nothing changes. Have re-loaded & done the Battle of Whiterun a number of times & the outcome is always the same. The danger/action music is constantly playing too. I dont want to try from handing in the Jagged Crown part again because of the issue posted next paragraph.

When returning the axe to Ulfrich to start this quest had the same sort of thing occur after his little talk in the war room. After his talk he should turn to me & say he wants me on the frontline at Whiterun blah blah but instead he would simply rant on about plans for the war such as cant believe we gave them the Pale before commenting how we have stopped the raping of the silver mines in the Reach. (i gave Dawnstar away in exhange for Markarth in the negotiations). Whenever he came close enough to me it would happen again also opening the dialog options. He would follow me everywhere too. Had to re-load & complete the entire Message to Whiterun quest several times before he finally gave the correct dialog.

These 2 issues have been evident since attempting the civil war quests 3 days ago & i started getting the backwards flying Dragons last night so the 2 options i will try are - deleting patch/updates & if that doesnt work a new character from the start of a new game.Ja50nX (talk) 23:50, December 6, 2011 (UTC)

-ok deleting update/s wont work as game wont even load. Asks you to install updates as save was created on later update. 1st time ever came across this & i delete patches reguarly to try & find out what was done in an update. So i started from scratch without any updates. Still had to do the Whiterun Dragon saga before the Jarl would discuss the axe. From doing these Civil War quests it became apparent this should be done last, after all main, side & misc quests. Needing to talk to people, complete other quests & accessing areas was a pain as had to trespass a lot which would not of occured had a number of other quests already been completed. Not sure if it was due to lack of updates but main issue with completing this quest was console freezing AND deleting up to 3 previous manual saves in the process. Having to re-do so many tasks made this questline take over 12hours from start to finish. Ja50nX (talk) 23:11, December 9, 2011 (UTC)

Siding with the good guys instead... Edit

Nothing is said about the quest to defend Whiterun (and MY HOME) from the traitor's assault.

I assume the outlying areas would be evacuated into the city walls, but will outfitting the townsfolk with "legendary" gear affect the outcome of the battle? (I have so much of it lying around the house after power training my smithing.) —Preceding unsigned comment added by 76.167.141.204 (talkcontribs)

( Please leave subjective analysis of good/evil at the door. )Ryanshowseason2 (talk) 17:03, December 15, 2011 (UTC)
They ARE traitors, it is NOT subjective. They are rebels and traitors and that's a fact not my opinion. —Preceding unsigned comment added by 76.167.141.204 (talkcontribs)
Actually... it really is an opinion. If you were more well read you might know this. I can suggest a few good sources for this but am too lazy to look up a precise quote for you now. SulhirVainamoinenGossipGold10 05:35, April 9, 2012 (UTC)

Please add the imperial version back Edit

That is all. No reason to make 2 pages for the same quest, even if the events are different. It just complicates things, even more so when the page doesn't even say "stormcloak side" or something. 69.132.69.87 22:54, December 19, 2011 (UTC)

As others have mentioned here, something needs to be done about putting the Imperial version back here, or at the very least, adding a link to the imperial version. I added a link to the Imperial version of the quest, but it has since been deleted. This is very confusing as there are 2 quests with exactly the same name, and if you search for the quest you only get info on the Stormcloak version, which is very confusing for somebody siding with the imperials.124.168.37.9 03:35, December 24, 2011 (UTC)
Note for anyone else editing this page - the Imperial version is NOT called Defense of Whiterun. It is called Battle for Whiterun. Apparently the strategy guide calls the quest Defense of Whiterun, but in the game, the quest is definitely called 'Battle for Whiterun'. 124.168.37.9 03:39, December 24, 2011 (UTC)

BugEdit

On lower end machines, the ammount of NPC's and some other things may cause lag. Due to this upon entering the city itself game will crash. There is no way around this. Although sometimes game can finish saving before the crash occurs, allowing player to reload the latest autosave and getting into the town. This does not occur in anyplace else in the game, no other sieges, including the siege of Solitude. —This unsigned comment is by Ikabite (talkcontribs) . Please sign your posts with ~~~~!

Cowardly Retreat?Edit

Any ramifications for skipping out on the Battle, if with Stormcloaks? AKA, any ramifications for not damaging Whiterun? 99.48.202.40 22:55, March 7, 2012 (UTC)

I believe that if you have the quest on your log, you cannot fast travel to the city. From what others have told me (I have not tried this for myself), if you simply travel to the stable and then walk to Whiterun, you find it garrisoned and ready for the quest to continue. However if you look at my bit below about Sanguine, it may still be possible to get around having to do that part of the civil war quest. EarthBoundMisfit (talk) 16:12, November 9, 2012 (UTC)

Innacurate Bug reported? Edit

One of the bugs mentions attacking a guard can somtimes turn Galmar hostile but I believe this to be false. I have tested a few things out and if you attack the Jarl in Dragonsreach before he turns hostile to you it will be treated as a crime and a 40 gold bounty will be applied to you for Eastmarch (the hold of which Whiterun is a part) and it is the BOUNTY that turns Galmar hostile and not simply attacking a guard. The first three guards who attack you will as a result will most certainly die. It is possible to save the three immediately before the Jarl by quickly nuking him and forcing him to call a cease fire before they die. Can anyone else confirm that the bug being reported is not a bug, but an intended game mechanic since the Jarl is being attacked prior to turning hostile.SulhirVainamoinenGossipGold10 05:40, April 9, 2012 (UTC)

Interesting Discovery Edit

I made an interesting discovery just now. I had the Battle for Whiterun quest going at the same time as A Night to Remember. The Whiterun quest was at it's beginning, where you are suppose to ask Galmar for orders. Before I got the battle quest however, Sam found me at the Bannered Mare in Whiterun and challenged me to a drinking contest, which started the Night to Remember quest. I finished the Night tto Remember quest FIRST and when he sent me back to where I initially met him it was the Bannered Mare... When I fast traveld out of Whiterun to go find my follower, it completed the quest, no battle necessary.

Only works though if you met Sam originally in Whiterun and you finish that quest before you do the Battle quest.

173.19.79.253 22:33, November 8, 2012 (UTC)

EarthBoundMisfit (talk) 22:35, November 8, 2012 (UTC)
Can you/another user confirm that this bug/exploit is reproducable. If yes then feel free to add it to page, if this bug is not reproducable then it was a one time glitch.Mask2697 (talk) 22:37, November 8, 2012 (UTC)
I will ask someone else I know who is playing the game to give it a try. I am not sure if it is only with Whiterun or any of the Imperial cities that Stormcloaks eventually overtake (and vice versa). Also, Sam doesn't show up in the same place every run through (first time I played it was Solitude), so it might be difficult to reproduce. But I will keep an eye out for it. EarthBoundMisfit (talk) 23:23, November 8, 2012 (UTC)
Sam will appear at the nearest Tavern when the player turns level 14. So actually it may be very easy to control his spawning if the player just holds of on leveling up until they are in Whiterun. I can make a new charactor and give it a try. If I confirm it i'll add it to the bugs.
Zelron Harbinger of the end times 23:28, November 8, 2012 (UTC)
I tried recreating the parameters as given, and surprisingly it is a bug. If I had to guess i'd say entering Whiterun from the inside screws with the flags. The game expects you to have entered from the front, initiating the battle, so when you leave it thinks that you must have completed the battle. Judging from this, getting arrested in Riverwood and sent to jail during this quest may have the same affect, but that'll need further confirmation as well.
Just as a side note about the bug, since there is more information than i'm willing to write in a single bug entry, it seems to sort of...make a dragon break. Balgruuf remains Jarl, the whiterun guards remain as the guards, and everyone inside Dragonsreach acts as if the Imperials won the Whiterun battle. Everyone else in the city act as if the Stormcloaks control the city, and Whiterun is marked as a Stormcloak territory on the war maps. I wanted to see how Vignar would act, to see if he thought he was Jarl or not, but for whatever reason Jorrvaskr became locked after the bug occurred so I can't get to him. This is all quite peculiar indeed.
Zelron Harbinger of the end times 11:20, November 10, 2012 (UTC)
I went back to Whiterun and wandered a bit to see what kinds of after effects I could find. In my case, Vignar is Jarl and the companions hall is still unlocked. There is one guard in Dragonsreach still marked Whiterun Guard but he is wearing Stormcloak armor. There doesn't seem to be any adverse effects that I can find in my game. At least, not yet. EarthBoundMisfit (talk) 19:26, November 11, 2012 (UTC)
Well I just traveled near the city, saw the siege happening, and not wanting to do that at the moment I quick traveled away to Riverwood. Suddenly the mission finished and Liberation of Skyrim started. I've never even talked to Sam or anything. Having returned to the city of Whiterun, I discover that the Companions hall does seem to be locked and the guards are Stormcloak soldiers (I'm on the Stormcloak side) the Jarl is Vignar Gray-Mane. So yeah... Strange bug. The Companions thing might be bad but other than that I see no ill effects.
Edit: The Companions Hall is no longer locked. Everything seems as it should be here now.
Kitsunedeshinu (talk) 13:11, March 13, 2013 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.