Elder Scrolls
Elder Scrolls

Well this is bad. I finished this quest with the Strange Amulet kept, and now I can't get rid of it. I got it checked out by Calixto but I still accused Wuunferth. It's stuck in my inventory as a quest item. What am I supposed to do with it now? I went back to both of them but after the first part of the quest I can't sell or appraise it. Am I stuck with it for the rest of the game? Drag3ndz (talk) 09:17, November 18, 2011

{C {C Drag3ndz, there seem to be quite a few items like that in the game - that will remain flagged as quest items, even after you're done with them - you may be stuck with it for now, but it is likely that there will be a patch to rectify (if it is indeed a bug) this in the near future.

There seems also to be another bug with this quest; by selling the amulet before talking to Jarleif, then talking to Jarlief without picking up the Journals, I seem to have prevented myself from accusing the Court Mage - if anyone else experiences this it might be worth making a bug note on the article. (Or, better yet, if anyone finds a solution to it, to make a note of that instead - I can't imagine that I'm the only one too dense to pick up incriminating evidence at first sight.) 16:19, November 18, 2011 (UTC)

I cant get this quest to start.I keep talking to the steward, he says some unpleasant stuff has happened and i cant do anything else. Talked to other NPCs around in the city, nothing.Please help me a bit, where/how do i get this quest started 10:20, November 19, 2011 (UTC) Skally

I did this quest today. It started when I accidentally stumbled into the cemetery area of Windhelm. It may be a Radiant quest, so you might need to do other things first. Also, your level might be contingent upon it. I was level 21 when the quest activated. If you meet all the requirements, I would try leaving the city and coming back. Hope this helps. --— Radical D (bother \ stalk) 10:28, November 19, 2011 (UTC)
I think you have to leave Windhelm once before Susanna will be a murdered. dumuh (talk) 00:30, November 20, 2011 (UTC)

I'm also having trouble starting the quest, I seem to remember seeing people in the cemetary but didn't talk to anyone because I was busy doing something else. I've spoken to everyone in the city and I've left and returned a number of times at different times of the day but there's still nothing. (I'm level 31 if it helps) 12:35, November 19, 2011 (UTC)

When I saw the people in the cemetery, I was forced to stop and talk to them. At any rate, I read someonwhere that the quest can be activated by entering Hjerim. --— Radical D (bother \ stalk) 12:38, November 19, 2011 (UTC)

Im also level 31, but never had an encounter with people at the graveyard.All i get is random folk talk about murders etc, but no quest. The place for it is outside the Hall of Dead right? Id hate to find out that im looking at the wrong place. Also, i cant seem to find any entrance to Hjerim , since i cant buy it and it wont let me enter. Steward says that there is an emtpy house bla bla, but due to unpleasant stuff going on, he cant sell it yet..

Meh :( 19:32, November 19, 2011 (UTC) Skally

Same here... I got inside the home by commands but nothing started... I think I DID read somewhere that you had to have the golden claw quest completed. Not sure though... I even got the quest where you need to find the Arkay amulet for the mother of the diseased daughter!

-LeiyaKerrigan 14:48 West-Europe 20-11-2011

When someone finds a working method, let us know! I did end up completing the quest, but it was super buggy. Every time I completed an objective, my journal wouldn't update, nor would the cursors on the map change. I had to figure everything out myself xD! At any rate, I hope you guys get it working, because this quest is actually really entertaining and fun. Remember Canvas the Castle? It's like that. --— Radical D (bother \ stalk) 14:02, November 20, 2011 (UTC)

Small update. You DO NOT have to complete the golden claw quest. Nor complete the Stormcloak rebellion quest-chain! I still can't get the quest to start... No one got murdered yet. I tried talking to every guard in Windhelm... Nothing! So please please please gather some information on how else to start it because I can't figure it out...

-LeiyaKerrigan 20:34 West-Europe 20-11-2011

O teh nose! I want to buy a house but can't. Wuunreth won't give me the dialog options. IDK what to do, the most imformation i get is from the bartender in the grey quarter. Is there a way to fix this, buy the house, and become Thane? (idk how to end this) -From Xerxes2113- (I guess...)

Hello everyone again! my personal update on this bugged (it seems) quest.

I pickpocketed Tova Clan-Shield, took the house key, went in, collected the Beware the Butcher! leaflets, also took the 2 Butchers journals! It wouldnt let me INVESTIGATE though at the crime scenes. There was an option to press E to INVESTIGATE, but it didnt work.

I went back to Viola, nothing happened, usual monologue of the NPC about slain women, beware the butcher, etc etc. Talked with the Steward, talked to Ulfric, talked to the mage, nothing happened.. Damn bugged quest! I want my quest + house!!

( :( 19:15, November 21, 2011 (UTC) Skally

I finished this quest and I still didn't get the house option. I did it in two parts by the way. Drag3ndz (talk) 19:42, November 21, 2011 (UTC)

Damn Bethesda! I looked for a quest start command but I found nothing... I know the quest id, (ms11b) stage numbers. (0-10-20) But no... No quest start command. Only SAQ to start ALL quests, but don't try that one...

-LeiyaKerrigan 23:16 West-Europe 21-11-2011

It seems that if you visit Windhelm and trigger this quest during the Imperial attack on the city it can cause problems too, so try and keep them seperate - though, judging by the previous comments, it may well bug out anyway, just for kicks. 00:31, November 22, 2011 (UTC)

Just a thought: after finishing the quest and stopping 'The Butcher', I got his key from his body, thereafter using it on the chest in his house and getting the other Butcher's Journal. Has anyone gotten the Butcher's Journal before killing him? If so, could it be used as evidence to lead to Calixto being arrested? Bvz-SA (talk) 23:30, November 22, 2011 (UTC)

I found this journal prior to starting the Blood on The Ice quest, at no point prior or during the quest did a text option appear that would let me show the journal to anybody. This leads me to believe that this quest was originally intended to be more expansive but that Bethesda decided to slack off. dumuh (talk) 23:11, November 23, 2011 (UTC)
At the point where I was to either show the amulet to Calixto or ask Viola about the Butcher, I snuck into Calixto's house and pickpocketed his key and obtained the Butcher Journal that basically says he is the murderer. However I too had no chat options to accuse Calixto when I tried to take it to Viola first and then Jorlief. In fact when I brought it to Jorleif it just gave me the option to accuse the court wizard, which I found odd considering I never showed the necklace to Calixto which supposedly is what needs to be done to make the accusation as Calixto points out that the necklace belongs to the wizard. February 12, 2012.

Hey everyone, I found a possible solutions for people who didnt found the body in the cementry and couldnt start the quest because of this...atleast it seems to work for me (playing on PC)... I didnt read the entire edit-page, so sorry if anyone stated this before, but I thought I let you know...
So I did the following, going into Windhelm, found no body in the cemetry, but everyone is talking about murder... I rememberd from a previous playthrough the the mother of the dead woman, Tora Shatter-Shield has a key to hjerim, so I waited till night, broke into her hous and pick-pocket the key... took me several attempts and reloads because im not playing a thief... then i was going to hjerim, took the journal and than the quest started... I just finished the rest of the quest, and it appeares to be done... only thing undone is the objective "look for details in hjerim" or something like that, hope this causes no trouble when im trying to buy the house...
Hope this help somebody! 01:45, March 24, 2012 (UTC)


Cannot start!![]

I also cannot get this quest to start! Here's my situation:

Level 41, am able to speak to the steward to buy the house but he keeps saying that there was an accident, Susanna the Wicked has yet to be killed, I took the Butcher Journal from Calixto, tryed talking to the wizard guy(name escapes me), I have tried to kill Susanna, but she is appearantly immortal... and I have gone in and out of the doors to Palace of the Kings, Candlehearth Hall, and the main, multiple times at different times of day.

So I have some questions, how do I get into Calixto's hidden lab, and how could I get this stupid lady to get killed? Please help.

Susanna will die when the following conditions have been met 1) You have entered and exited Windhelm atleast 4 times and 2) You not in the main town at night after meeting condition one. You can't complete this quest until Susanna dies unfortunately. dumuh (talk) 23:35, November 23, 2011 (UTC)
I met both conditions... nothing. (Sorry forgot to sign earlier.) Living Lifeless 9 23:51, November 23, 2011 (UTC)

For PC-users, you might be able to force state the quest by using the command console code:

setstage MS11 1

--— Radical D (bother \ stalk) 00:01, November 24, 2011 (UTC)

Unfortunately not. I have tried that, as well as the following:
SetStage MS11b 1
SetStage MS11PreEssentializing 1
StartQuest MS11PreEssentializing
StartQuest MS11
StartQuest MS11b
CompleteQuest MS11PreEssentializing
CompleteQuest MS11
CompleteQuest MS11b
By using the CompleteQuest command it displays the quest completed text on-screen, but it still doesn't add it to the journal, people also continue to talk about it as though it were not completed. Even using the StartQuest command doesn't seem to work. Troodon80 (talk) 08:41, November 26, 2011 (UTC)
I don't play this on PC so I cannot just use commands to skip it, but I surely would if I could. I'm still stuck on what to do, could someone tell me how to access Calixto's "hidden lab"? I'm trying to find other ways of triggering this quest, as it seems the murder will just not take place, and I will never be able to but the house :( --Living Lifeless 9 16:05, November 26, 2011 (UTC)

This person got it...[]

(For some reason this was in the bugs section of the actual page not in the talk page, where it should have been --Living Lifeless 9 16:02, November 26, 2011 (UTC))

  • Ok, so I couldn't do the Blood on the Ice quest, not sure why but it was broke. But, straight to the point. I wanted Hjerim. By trying multiple things I found here, and other places, I managed to unlock the house, and am able to purchase decorations from the Jarls steward, house is unlocked. So far so good. This is what I did.

    First buy the house, you must have 12,000 gold on you for it to work.

    setstage 000A7B33 10

    Second, I dont think this did anything, but this is what I did, so try it. lol. What I did was I forced the dialog to get the decorations. What I did was, I walked up to the steward and had my crosshair hovering over him. Went into console and put...

    say 000E67B8
    say 000E67B6
    say 000E67BA
    say 000E67B5
    say 000E67B4
    say 000E67B9
    say 000F726A

    That didn't do anything but give me back a bunch of crap about faction and quest stuff. So then I thought, hey I didn't finish BOTI yet... So, I entered...

    completequest MS11

    Once I did that I talked to the steward, still no decorations. So I went back to the console and I entered in a nerd rage.

    say 000F726A
    say 000F726A
    say 000F726A
    say 000E67B9

    Then, I talked to the steward. Guess what? I can buy decorations! and they work!! hahahahaha. Just make sure you clean up the blood first.

    Some other things I tried was resetting the at with ResetAI on that Wicked chick and Calixco but that didnt work either. Im stocked this works for now. I can finally continue on with my life in Skyrim.

    Brought to you by: Vitalsine

After trying many different ways the trigger the Blood on the Ice quest eventually I gave up and decided to cheat. I got the house by following the steps below:

  • setstage 000A7B33 10 (need 12,000 gold for this)
  • completequest MS11
  • completequest MS11b
  • then I was able to purchase decorations, first was to clean up the mess
  • went to the house to make sure the clean up worked
  • back and purchased the remaining decorations

The only downside of this was some of the decorations did not really work and for I now have barrels in bookcases, chairs in the bed, just a few minor glitches. 00:18, January 14, 2012 (UTC)

"Entered and exited Windhelm 3 times"[]

This is totally wrong, I started this quest on my first visit to Windhelm. Unless "enter and exit" also refers to going inside a house (I went to see Arentino) in Windhelm and then going back out.

Agree with you. In my case, after I entered Windhelm for first times (when I entered, it is around 11PM, and my character is level 50), I went to The White Phial (because of the Wylandriah quest to find her Soul Gem). After got the Soul Gem and talk with shopkeeper inside, I exit the shop, run to the graveyard and already have this quest started. I think I didn't "entered and exited Windhelm" for 3 times... --Tan pang (talk) 19:34, December 25, 2011 (UTC)

Given when entering house[]

This quest is also given when entering the Windhelm house for the first time. If this is the case, the quest starts at step 9 in the walkthrough, after entering the house at the first time.

Thought this would be worth noting 20:34, December 12, 2011 (UTC) Lt. Plate

If anyone is having the bug where even after three days and after accusing the court mage another dead body still doesn't appear outside the Hall of Kings, than all you have to do is go inside and talk to the court mage (who is realeased from prison). You can say "Another body has been found" and the quest will continue. Hope this helps! StarlinSkyrim (talk) 23:44, December 12, 2011 (UTC)StarlinSkyrim

Ok so, I did this. I stole the key from the lady and walk into the house. Nothing happened. I even picked up both journals and the amulet. Still nothing. I went back to an older save. Nothing. I have even tried the console commands and yet again, surprisingly enough, nothing. Can someone please give me some ideas. Thanks. Also, I am on a Mac... That might be the cause of the problems. 16:53, March 14, 2012 (UTC)GrayHamCracka

He and some of the others may mean that entering the house after buying it will trigger the quest. I hope it does, anyways but I haven't tried yet. Can anyone confirm the new addition of the this supposedly locked page that Calixto will try to murder your wife if she is from Windhelm? And does this replace the hidden requirement that Arivanya has to be alive for the quest to start? That's another bug, by the way. Arivanya should not be required for this quest to start since there are plenty of other equally logical candidates for Calixto to murder. 08:28, July 17, 2012 (UTC)


Please, who are the additional victims and what deaths can be prevented (names)? Retardedmoose (talk) 02:01, December 15, 2011 (UTC)

This is bad, I found the Butcher's journal if the Butcher's house before starting the quest, now I can't start the quest. Any help? (Xbox)

I'm unable to start the quest, but I'm on the xbox. Lvl 47, I've got the flyers and the journals.. The amulet.. I can't even buy the house. Little dissapointed.

Yeah same here. I have got EVERY quest item, key to Hjerim, bu can't buy the house and can't trigger the quest either. I play on PS3. Jizzytatsu (talk) 19:07, January 8, 2012 (UTC)

Can any of the people above, if you're still trying to do this quest, please confirm if all people related to this quest at all are still alive? Especially Arivanya. I have tried to start this quest with my only character many times, and some of those I'm certain that stupid elf was still alive and complaining. Apparently she's died at some point since I last confirmed her existence, though, and now I fear that her death will damn me to not having Hjerim because I cannot start this quest, but I will have to keep hoping, get the patches, and take Windhelm for the Imperials and see what happens. She should not be essential to this quest, but some uesp must have found evidence indicating that for some stupid reason she has to be the one killed after Sussanna the Wicked, when it should just be any random woman. She's not noted in the diaries after all. 09:05, July 17, 2012 (UTC)

The article says that the Butcher will try to kill Arivanya while you are patrolling at night. I'm pretty sure the woman he killed for me was a human not an elf. I think she was wearing a reddish dress. Really annoying but I cant remember her name and the body is gone so I cant check. Monkey-_ 14:24, April 11, 2012 (UTC)

Quest dosen't start after joining the Empire and taking over Windhelm?[]

Is it true that you can't start the quest "Blood on the Ice" anymore after you joined the Empire and ended the Civilwar by taking over Windhelm and killing Ulfric?

I walked several times through the graveyard at night. But the quest never started. But somehow I got the key to Hjerim. I don't remember how. Well I tried to open the door and entered the house. I found two journals of the Butcher and a strange amulet... 16:51, December 30, 2011 (UTC)

So I was playing the second part of the quest (where you find out the Mage isn't the murderer) after I helped the Imperials fight over Windhelm. He said to patrol the streets at night (this was at night) and that objective immediatly and told me to confront the murderer. The murderer went into Hjerm and went into the secret room (please note that I never found that room or amulet when investigating the house) where he just stands there and and occasionally fights me but never actually dies (just kneels), I heard that just doing a few more quests will fix this and it didn't and the save before that was three hours before so is there a way that I can fix this without reverting a save (XBOX btw) Thanks those70sfans owner of the Creature wiki, I heart you! 00:25, January 1, 2012 (UTC)

Cannot initiate this quest, currently midway through the Brotherhood questline. Really frustrating as there is no reason that this should have ANY impact on this quest.

I have tried the following, and can confirm that they do NOT work as an alternative solution.

- Breaking into Calixto's and stealing his butcher journal, then speaking to Jorleif.

- Breaking into Hjerim (key from Tova Shatter-shield), stealing the Amulet, and visiting Jorleif and/or Calixto.

- Speaking to Viola Giordano before or after entering Hjerim and taking one of the pamphlets.

Someone earlier also mentioned that purchasing Hjerim before starting the quest can officially end the possibility of finishing the quest. Is there some way to do this? I only want the house, and when I visit Jorleif, he mentions some 'unpleasantness' and I was unable to purchase the house :/ The Advocate (talk) 04:12, January 9, 2012 (UTC)

I have tried several ways to start this quest after winning the Civil War for the Imperials and cannot get the quest to start. It would seem that the only way to get this house is not to side with the Imperials. 23:49, January 13, 2012 (UTC)

We both sided with the Stormcloaks. One of us , (the son), has finished the war, while Dad is stuck half way through by a bug, (Fort Sungard won't spawn any Imperials). Neither of us can get the quest to start, both before and after starting the Brotherhood quests, so siding with the Imperials or doing the Brotherhood quests don't seem to be the problem. DarthOrc (talk) 07:18, January 14, 2012 (UTC)DarthOrc

I have started this quest but can not finish it, due to i can find the Viola Giordane. What do i need to do? Zolm (talk) 23:10, January 14, 2012 (UTC) Zolm

I can not find Viola Giordano. Zolm (talk) 23:12, January 14, 2012 (UTC) Zolm



There's an old slasher flick by the name Pieces (I hear it's been distributed under other names also) in which a college is plagued by murdered co-eds, the girls are always brutally dismembered... parts missing, like this, and in the end you learn the killer (whom I won't identify) was trying to re-create his long-dead Mom with parts from the victims.

I can't finish this[]

Mustafa Reyhan (talk) 21:42, January 22, 2012 (UTC)

First I do quest and I thought the court wizard is butcher and court wizard go to prison.I bought the house and all decorations and I clean up mess.And then like 2 or 3 days I play game.Then I go to the windhelm jail court wizard was there I talk to him and he sayed he is not the Butcher then say Butcher will on rock street(or something like that) and I must go that street on night but it was night then I go to street but quest marker shows the Hjerim it means my house I go into Hjerim Calixto was there he go into scret room but he don't do anything he just waiting there and attacking me sometimes.I can't kill him and I can't use alchemy thing and enchanting thing because it says "you cannot use it while enemies are neaby" please help me.I am playing on PC.Sorry for bag english.

If your playing on PC then you have some hope. You have either to find the command to force the NPC's action in the quest or you can auto complete it using the " finish quest " command. Another thing you can do is to use the spell that calms enemies. Try if that works.....

Blood Reaper (talk) 21:52, January 22, 2012 (UTC)

I try calm spells, when I cast calm spells on him I can use arcane enchanter and alchemy lab but he is still in my home.Is there some way to get back altar in the secret room? May be I wrong but I think I must catch him while he doing something with altar but I clean altar and he don't do anything.

PS3 - After initially questionning the witnesses, the quest points you to speak to the guard, which you can not

There's supposed to be another step before, but it kept telling me to speak to the guard by the mudered body, everytime i did she didn't do anything (just had a stand ard, can i help you response)

i play on the xbox 360, and own 2 profiles, one of which i was given the quest, and the other NEVER recieved the quest.

the only sucumstances for me getting the quest the first time was i had NOT progressed in the dark brotherhood questline, but had started innocince lost. on the second i had completly finished the DB questline.

i came to the conclusion that compliting the DB questline BEFORE trying to start the quest will make it impossible to get the quest or buy hjerim.

Quest start?[]

So, I play on the 360, I'm a level 43 Kajhiit, and I managed to win the war for the Stormcloaks. I also have completed the Dark Brotherhood questline.

I try to buy the house from the steward, and he keeps saying that there was an incident, and it'll be ready soon. I also cannot get people to show up in the graveyard to start the quest. Any ideas?

-PARADOXintent 19:18, February 5, 2012 (UTC)

Starting the quest[]

I played on PC and I tried starting the quest with a level 38 Imperial (finished Winterhold College Questline), but the starting event about guard finding the bodies dind't occur. I tried using cosole command

startquest ms11

but it also didn't work.

Later on my brother tried it with his lvl 9 Breton (just started the game) and the quest started accordingly. Then I tried my backup save (the same character as above, just finished Helgen) and the quest also started normally. I also tried the console command, and it worked too.

I was wondering, maybe this quest has to be started before finishing any questline (e.g. Companion or Winterhold College)

Vitho.drego (talk) 12:47, February 8, 2012 (UTC)

Cannot retrieve key from Tova because she's DEAD. [SOLVED][]

I am so frustrated!

I have been working on this quest for a while. Not only are there many markers randomly placed throughout this quest, and aside from the massive glitches, I have a serious problem. I've completed the Dark Brotherhood Questline before doing this quest, and I think you know what that means. If you don't, I'll explain it.

Apparently, you're able to purchase Hjerim after completion of this quest, right? First, you must investigate the house. Right. Okay, so, I have a lockpicking skill of 70, and I've just begun picking expert locks after using 2 -4 lockpicks. It's completely impossible to pick master locks at the moment without wasting 15+ lockpicks. And as you might know, Hjerim has a master lock, leaving the lockpicking option highly unfavorable, especially since I'd have to wait to lockpick it for a while.

That leaves me one other option - to get the key from Tova Shatter-shield. Here's where I'm having a problem:

Tova Shattershield has two daughters- Friga and Nilsine, and she's married to Torbjorn. Now, Friga is dead and there is absolutely nothing one can do about that. A girl named Muiri, a family friend, often expressed remorse for Friga's death. Then, her ex-lover Alain uses Muiri's grief for his own selfish desires, destroying her relationship with the Shatter-Shields. Upon joining the Dark Brotherhood, I recieved a contract from Muiri to kill Alain. There was an option as well, to kill Nilsine Shatter-Shield, I think because she hated Muiri after what Alain did. Me being one to complete quests completely for extra-rewards, killed Nilsine.

Now, Tova is in serious grief from Nilsine AND Friga's death, and ends up committing suicide (a letter next to Torbjorn's bed shows her suicide note). Much later is when I got the Blood on the Ice quest, and it wasn't until now that I realized that I need Tova to retrieve the key for Hjerim..........Her body is nowhere to be found and I don't know what to do?

I have options:

-Find Tova's body (The question I have is where would it be, and would the key still be on her corpse?)

-Lockpick the door (I will have to wait a seriously long time to get my lockpicking skill up, and I want to finish this now.)

-Use the command console to get the key (I don't know it's number and I haven't cheated once on this game yet, and I don't plan on it :c)

So guys, any suggestions as to what I should do?

Sorry that this is long , please don't tl;dr, this is srs bsns.

"Find Torva's Body"
  • There's a special place where important dead NPCs are transported to when they die, she may be there. It's only reachable by console command.
"Lockpick the door"
  • Lockpicks are rather plentiful so using a dozen or so to open a door isn't really that bad. This is the only non-cheating option that I can think of.
"Use the Console"
Simplest solution:
  • Walk up to the door
  • Open console
  • Click on the door
  • Type "unlock"
  • The End
It's not really a glitch, just a consequence of murdering people. :p
Louthar (talk) 05:57, February 9, 2012 (UTC)
Thank you so much, I'll just unlock it. I guess everyone cheats sometime ,eh?
And yeah, I should [probably] stop killing every NPC that I can...at least until they're not valuable anymore, haha.

problems starting even with 1.04[]

help! i still cannot start the quest EVEN AFTER PATCH 1.04!!! i talked to everyone in windhelm even viola giodano

i even entered the hjerm with the key that one girl had nothing! read both bucher journals NOTHING!!! help!!!Gutarjunky (talk) 04:05, February 10, 2012 (UTC)

I believe if you reset the quest you can have it progress normally and you can do that with the removequest command to restart it, alternatively you can use consoles to get a bugged to hell hjerim

Reopening the case[]

I actually believed that I had solved this case and the wizard was the culprit.... Until I slipped some poison into an NPCs inventory and she dropped dead, and the guards approached me and told me the butcher was still out there, and they thought I had caught him.... This reopened the quest for me. (360) 05:48, February 14, 2012 (UTC)DrFejj

Did you pick up the Beware the Butcher! pamphlets? Sometimes you have to grab multiples and read through them. If that doesn't work, your next objective to speak to Viola Giordano, so try locating her around Windhelm.--—Deyvid Petteys (bother \ stalk) 16:54, March 14, 2012 (UTC)

This is soooooooo stupid! Nothing I do will get this quest to start. I called Bethesda and downloaded the updates, tried everything mentined. NOTHING!!!! NOTHING WORKS!!!!! This quest and that house are the reason I got the game. I want my money back or a patch that works 100% NOW!!!!

I am not sure if this is directly related to the quest but colixos house does not seem to open during the day during the quest. 14:33, March 22, 2012 (UTC)

Guard Problem[]

I hadnt got any where far in this quest only to the point where I had to investigate the people.When I finally went back to this quest and questioned the three people around the table thing then it told me to report to the guard that got me to start the quest.Now this is the buggy part,I followed the map marker to try and find the guard,I walked around a bit trying to determine the guards location (I also used the local map).I could not find the guard for my life so I used clairvoyance,the trail led me to the foundation (the stone) of the Windhelm blacksmiths house,the trail goes into this foundation into a kinda untextured smooth wall panel.I'm playing on the X-Box 360 so I cant use console commands to no clip my way to the guard.I do not know if this is somewhat related to the listed bug the guard might die after investigating the people.

PS:Being dumb me I only had one manual save point the whole game so I could not revert save to a less recent time.

Solution: I'm not entirely sure if this will work, however it seems linked to this glitch. I encountered the problem on the PS3 where you can't start the quest if you have attacked one of the guards, so I proceeded straight to Hjerm which triggered the quest, but further along. Perhaps if you proceed straight to Hjerm it will bypass the part where you have to speak to the guard after questioning the witnesses as you investigate Hjerm later in the quest, therefore if you progress straight to Hjerm it should hopefully bypass you having to speak to the guard. As I said, I'm not sure if it will work as I used Hjerm to trigger the quest, but way I see it it is the same principle.

Steps of Quest[]

I would suggest that a small note is added for the step 6 that is written to add -Can also talk to a guard to get information about Tova Shatter-Shield.

what to do if Viola may be dead?[]

i play on xbox and i have done everything needed but when i go and talk to Jorleif about it theres no dialogue for it and when i went to find viola the marker tried to take me under the bar at the center of town and now theres no marker for her at all, is there any way around this? ive tried everything i can think of. —This unsigned comment is by (talkcontribs) . Please sign your posts with ~~~~!

The 1.5 patch that is being released soon is supposed to fix this problem. The fix states that: "Killing Viola before or after “Blood on the Ice” no longer blocks progression". So, all hope is not lost, you just have to wait it out for now. —TombRaiser 05:32, March 29, 2012 (UTC)

If you can´t talk to the gaurd after talking to the vwitness, try to pay of any bounty and then try again. 13:27, April 5, 2012 (UTC)

Blood on the Ice quest with Imperial questline done and Dark Brotherhood triggered debugged.

I think I found a possible solution to the xbox bug with Blood on the Ice, the quest involved with the series of murders in Windhelm. I wanted the house Hjerim so bad so I did not save any of the quest so I did not get stuck with the buy if I couldnt upgrade it. I also ended up triggering the Dark Brotherhood by mistake before this, so I had to find a way to get the house.

What I did was - First off, do not save any of this so you do it right and if you mess up you can start over anytime.

1. As you go to the palace in Windhelm I noticed Jorleif the Jarl's steward offers to purchase Hjerim (house), so I went out before purchasing I asked the Jarl, Brunwulf Free-Winter (if you chose the Imperial over Stormcloaks) for the Thane quest to see if you could do so.

2. So the Jarl allows you to become Thane, and you finish the quest to help the citizens of Eastmarch, and all the quest giving by the steward if you can.

3. Buy Hjerim from Jorleif, and proceed to Hjerim, which activates "Blood on the Ice", seach the clues in house even the amulet.

4. Viola Giordano must be talked to about the pamphlets found in the house called "Beware the Butcher", after this you will see the quest sends you back to the steward, or you can talk to Wuunferth the Unliving, the Jarl's wizard.

5. If you talked to Wuunferth the Unliving, go back outside and catch Calixto commit the final act near the blacksmith area , and on turn in to the steward the quest is now complete and Hjerim upgrades are avaliable.

If there is information on this already, disregard... I just find it hard to read a wall of text when looking for answers..

If this is helpful.. your welcome.. Glad I could help.. Reaper77515 (360tag)

Add this when you can. Infinite gold via this quest; loot the Strange Amulet from Hjerim, sell it to Calixto, steal it back, resell it to him, repeat forever. You're welcome. Didn't bother trying after the quest, just spent a good hour racking up about 150k and called it enough to last the game.


Okay so I have a problem to. I am playing on pc. I started the quest normal and got into the house. I also have Skyrim for the PS3 and when you enter that kill room there should be an emulet. On my pc there is no emulet. So now I am stuck and can't go further with the quest or buy the house. Can someone help me, I am willing to put in commands to let it work but I don't know whitch....

Greetz. ~~Jurrocane~~

Jack the Ripper[]

This quest was obviously inspired by the "Jack the Ripper" murders. Can someone please add that to trivia?

Moogleknight24 (talk) 23:29, May 19, 2012 (UTC)Moogleknight24

I think the reference to a movie someone discussed above is much more valid. Unless I'm mistaken, while Jack the Ripper did murder only women at night, he was not gathering body parts to attempt necromancy to bring back a loved one. 05:10, July 1, 2012 (UTC)

when i discovered this quest, it was past midnight. and i think this quest is inspired by Jack The Ripper too. he was never caugh, which means noone really knew he's motive. maybe he killd woman for theyr bodie parts to put he's wife back to life. maybe he tried to sell them. cannibalism maybe, noone really knew, i see the possiblilty of this being a refferance highly possible. im just saying, if you do the quest again and think about it, follow the leads, and you'll discover that it leads as far as the Jack The Ripper Case got, even abit futher with imaginations.

Funsoms (talk) 17:36, October 1, 2012 (UTC)

"Beware The Butcher!" Glitch?[]

I do apologize, but I'm not very used to how the format of these pages work, or entirely familiar with wikia itself just yet. Anywho, during the quest Blood on the Ice, where said 14 copies of "Beware The Butcher!" were inside Hjerim, I picked them up. But during the time that quest was ongoing, the flyers continued to somehow multiply and multiply within my inventory, and I was not picking any more up at all. I didn't think it would be a problem, although the game has been lagging majorly at various parts for the past while, such as on loading screens, looting enemies or searching containers, exchanging goods with my followers, selling or buying goods, and so on. I just read on the item's article that it may cause a glitch where the Character Menu lags, though it only said for 360 and I've been playing on PS3. I already got rid of the "Beware The Butcher!" pamphlets by selling all of them to my spouse at once, and the game did seem to be much, much faster for the remainder of the time I was playing, but I'm still not too certain about this issue. There were over 10,000 copies of the item before I ended up ridding them from my inventory. Has anyone else had this issue, and if so, does simply ridding the items from your inventory cause the problem to stop altogether? It was really lagging my gameplay for that specific game-- and although it seems to be all right now I just hope it stays that way for good. Tigerpuppy (talk) 02:21, May 28, 2012 (UTC)Tigerpuppy

Cannot accuse anyone[]

I've followed up on the clues to the point that I found where the amulet supposedly came from (I got bored and robbed calixto figuring out he's the guy, but I won't get into that right now). When I talk to the steward, there isn't an option to accuse anyone. I'm pretty far into the civil war questline, on the imperial side, so that may have something to do with it.

please wuunferth walk one step closer to me i cant reach youo :P

is there a way to start the quest via console command if the people on the graveyard don't appear? 22:30, June 15, 2012 (UTC)

I can't accuse anyone because the advisor guy doesn't have an option to accuse anyone, despite the quest target above his head.

Unpatched Bug: Starting the quest with an Imperial-run Windhelm[]

Suggested addition to this page under Unpatched Bugs: How to start this quest after completing the civil war quest line in favor of the Imperials:

After having sided with the Imperials and sacking Windhelm, this quest will not be completable without the use of the console (barring any fixes in future updates). When you hear around town of the attacks and see the dead body, there is no "Windhelm Guard" to give you the quest, only "Imperial Guards". So you have to give yourself the quest using the console command setstage ( Console Commands (Skyrim). It's important to note that there are two versions of this quest and thus two different refids ms11 and ms11b. The command: setstage ms11 10 will start the quest, assuming Susanna the Wicked is the only dead girl, however there is one more obstacle. After completing the objective for talking to the witnesses, use the console comand setstage ms11 30 to bypass talking to a non-existant guard. The rest of the quest should complete without a hitch, provided you haven't already purchased Hijerim. Sometimes by entering the graveyard even after sding with the imperial forces and taking windhelm has been completed the quest may be given by an imperial guard.

Updated with new information[]

I have found that [i can only confirm for XBOX 360] if you have completed the Imperial questline, as well as the "Destroy the Dark Brotherhood" mission before attempting to start "Blood On The Ice" the only way to start the quest is by stealing the key to Hjerim, "skipping to step 9." This deprives the player of the entertainment involved with hearing the initial story/circumstance and investigating the first few characters.

The graveyard start to the mission never occurs, whether waiting until around midnight and traversing the graveyard from within Windhelm initially, or waiting until around midnight from outside of Windhelm and entering the city/heading to the graveyard.

"Destroy the Dark Brotherhood" quest in combination with Imperial questline seems to be the only ingredient that lends to the problem, as others have completed the Imperial questline only and have still been able to start the quest by other means.

[PS3]I've finished the Imperial questline and am doing Mourning Never Comes, but I managed to start it. I was coming out from the Palace if the Kings and the time was about I dunno, near 12:00. So I figured I'll use the "backdoor solution" (search youtube). Then I went straight to the graveyard and there are the people standing around. And yes, it was an Imperial guard. 06:21, April 16, 2013 (UTC)

Xbox 360 Bug[]

OK. I play on Xbox 360 and I've completed the Dark Brotherhood questline and I also completed the Imperial questline. I've stolen the key to Hjerim and I have taken all the fliers of Beware the Butcher and the amulet. I went and talked to the jarlief guy and he has the option to buy the house, but only tells me that there have been some incidents and the house isn't quite ready yet. I read on here that there is a way to still complete the quest on 360, so please someone help me out.



ssince i cant edit it myself ill just notefy that the bug list contains multiple typos anc incorrect use of english such as hiding in the room IN the wardrobe which should be behind the wardrobe also some of the npc names are not capilatized and are sometimes are written incorrect Wesleyeye (talk) 14:51, July 24, 2012 (UTC)

Ive tried everything but cant get blood on the ice on my xbox 360 can someone please help

Ive tried everything but i cant get blood on the ice quest on my xbox 360 can someone please help 19:04, August 10, 2012 (UTC)Lz483 (talk)


I'm palying the game on xbox 360 and it has glitched. What happened is that the Quest marker is above jorlief but i don't have any new speech options please help. (ps. i have sold the wheelstone to calixo.) 15:13, August 11, 2012 (UTC)

I'm on the PS3 and I wasn't able to get the quest to initiate normally so I used the workaround of stealing the Key of Hjerim from Tova Shatter-Shield (or at least I think that was her name). Anyways I'm only posting to say I found a workaround for Calixto's House of Curiosities being permalocked when told to go find him for the first time. The quest didn't show any of the usual markers on the map but on my compass thing there was a quest-in-door marker parked right atop Calixto's House of Curiosities. So what I did was wait for an hour at a time for about 5 or 6 hours during the day until that quest marker was no longer at the door indicating that Calixto wasn't in his house but was somewhere in the city. I then followed the quest marker to him and talked to him to get him to buy my strange amulet and completed the quest as normal. Hope this info makes it into the wiki article.

Yeah, I was asked to go get advice from Jorlief, then examine the grave or something (Quest markers above Jorlief and the grave). Jorlief doesn't have anymore quest options and the jornal states I need to talk to him? This is after the part where I spoke to the old lady in the hall of the dead. Yumeyo-yuki (talk) 14:42, November 18, 2012 (UTC)

Workaround for permalocked House of Curiosities[]

I'm on the PS3 and I wasn't able to get the quest to initiate normally so I used the workaround of stealing the Key of Hjerim from Tova Shatter-Shield (or at least I think that was her name). Anyways I'm only posting to say I found a workaround for Calixto's House of Curiosities being permalocked when told to go find him for the first time. The quest didn't show any of the usual markers on the map but on my compass thing there was a quest-in-door marker parked right atop Calixto's House of Curiosities. So what I did was wait for an hour at a time for about 5 or 6 hours during the day until that quest marker was no longer at the door indicating that Calixto wasn't in his house but was somewhere in the city. I then followed the quest marker to him and talked to him to get him to buy my strange amulet and completed the quest as normal. Hope this info makes it into the wiki article. 10:49, August 19, 2012 (UTC)

If you pickpocket cakixto when you first meet him, and use his key to open the chest in the loft — you can read his journal which essentially admits to being the killer — Then after talking to the court mage, instead of waiting for him to show up to the murder in the marketplace, you can just go kill him in Hjerim to complete the quest

1.5 bug blood on the ice[]

1.5 not starting again!?[]

ok so as from my previous post, 1.4 made the quest work if you go back on an earlyer save

now im starting a new game on 1.5 first time i enter windhelm people already talking about the butcher

no murder scene and when i steal the key from whats her face

and enter hejerm and read the note QUEST DOES NOT START!!

did bethesda take out 1.4 patches or something because i know for a fact this bug was FIXED IN 1.4gutarjunky (talk) 17:18, September 15, 2011

Calixto's House Of Curiosities locked[]

I have had the problem that his shop was locked and i had to break in, therefor not getting invited to a tour.

I have found a way to solve this though, simply just exit the shop when he tells you to and then re-enter and then you can continue the quest86.52.50.146 05:06, September 20, 2012 (UTC)

The above solution didn't work for me, he just kept telling me to leave. The solution that I found is to wait until Calixto leaves his house. He won't be hostile and he'll buy the amulet. The tour won't be available, but it's not really worth the two septims. ~On the wings of fire and devastation, I return. (talk) 04:22, September 19, 2013 (UTC)

Can't Accuse Calixo[]

I got him to do his tour, jacked his key when he turned around, unlocked his chest, took his journal, and read it. He never figured out what happened. But now that I know it's him for sure, my only option to accuse anybody is still just for the court mage that I know didn't do it. So now to get to the end of the quest, my character has to behave like a moron. 02:35, September 27, 2012 (UTC) ap0state

Quest finished without amulet[]

finished quest without amulet then went and got the amulet later. waited for second body to show up but quest won't start. i talked to the guard and to the mage whats-he's-bucket. he told me to watch the stone something-or-other the next night and i did but nothing happend 03:26, September 27, 2012 (UTC) Me

The Stone Quarter. Anyway, now that you picked up the Strange Amulet, you're more than likely going to have it stuck in your inventory, because if you had sold it to Calixto he would have changed it into the Necrmancer's Amulet and that would have been able to be looted from his corpse. As for the next body not showing up, I would look in more than just the Stone Quarter, because when I looked for the second body, it showed up nearer to the Palace of Kings. 04:55, September 27, 2012 (UTC)

"Wait I Know You"[]

I talked to the guard, and he told me to ask the people if they saw anything. I did so and got the next step which is to report to the guard. Okay, so every time I try to talk to him all he says is "Wait, I know you". How do I get him to stop saying that? In my general stats it says I have a 250 bounty in Eastmarch...but I'm not sure if that means it's an unpaid bounty or just that I had one at one point. Also, nobody is approaching me regarding paying it...if that is what is required to move forward.

Thanks in advance for any help with this...I'm going to keep trying in the mean time to find a solution.

PS - I also tried talking to Jorleif as step 3 (?) mentioned, and all that resulted in was a bounty on a giant.

[[Special:Contributions/|EarthBoundMisfit (talk) 03:45, October 10, 2012 (UTC)]]

Maybe go out of the city. Go to Kynesgrove (it's part of Eastmarch) and find a guard there. Maybe you can pay off your bounty over there? —TombRaiser SPEAK! 03:53, October 10, 2012 (UTC)
EDIT-- Perhaps this could be added to the main page tips section... if you can't get the guard to talk to you, and he just keeps saying "wait, I know you" then try unequipping all of your weapons and just smack him until he tries to fight back. Then when you stop fighting, he'll give his spiel about breaking the law. Pay the bounty and he'll talk to you again,. I say unequip weapons, because if you're high enough level then one hit with a weapon could kill him.
EarthBoundMisfit (talk) 01:25, October 11, 2012 (UTC)
I've just had the same bug on the X360a few minutes ago, the guard kept going into the default "Wait, I know you..." speech a number of times - he finally stopped when I had some spells armed but wasn't attacking (I'd used the persuade option before when I was unarmed). I had armed my spells with the "X" button just before the 4th/5th try (afraid I wasn't really counting!) and this time there was the option to say "We both don't have time for this". After choosing this he finally began to respond regarding the quest... The guard was marked as the target for the quest throughout. It's a definite bug, but it's not clear what stops it, maybe just equipping weapons (or fists) is enough? - Blue_Sonnet 05:16, October 12, 2012 (UTC)

Updated with new information[]

BUG SOLUTION: Calixto just stands there, does not attempt to kill Arivanya. [SOLVED][]


Kill Arivanya yourself, you will get bounty added to you, then immeditely kill Calixto, the bounty will get away due to the [last witness killed] feature. and the Blood on Ice mission can be completed.

Updated with new information[]

I found another bug for the Xbox 360. After you talk to Jarlief and are directed to investigate the crime scene, DON'T go talk to Helgird first and then talk to the guard. I did that at first because I was confused (the little quest arrow was pointing to the stone thing on the ground and wouldn't do anything when I clicked it. That's how I got confused) and decided that talking to Helgird first might progress the quest, so I did. After that I talked to the guard, and then the guard directed me back to Helgird. So I talked to Helgird again and all she would say was "Large diagonal cut from left shoulder" or whatever she says and wouldn't initiate any dialogue. She would just repeat that over and over. So, add this to the bug section possibly? I hope I explained it well enough. I fixed it by loading an earlier save, before I talked to the guard or Helgird but after I talked to Jarlief. 04:38, December 22, 2012 (UTC)

Small bug found on PS3 version

Despite the description, Calixto will sometimes attack Arivanya in broad daylight (when I did it, he tried to attack her around 4 P.M.).  Not a huge bug; but users may want to be aware of it just in case they want to rescue Arivanya.

Graveyard scene bug.[]

I am unable to start this quest at all, the graveyard scene is there but there is no guard to talk to. Its possible vampire attacks killed the guard but I have ever visited windhelm once on this file to start the dark brotherhood missionsand I am pretty either no vampire attack happened or I killed them before any casualties happened. note that the graveyard scene was like this before I even killed the daughter of the shatter-shields for the dark brotherhood. Is there any way aroundf this? I hear going to the house is an option but ti says that will only work if the graveyard scene has not been triggered which it has. 18:59, January 13, 2013 (UTC)

So the guard was killed for me, I fixed this by resurrecting him using console commands.

Just enter the command: resurrect <010009ac> 

That should fix him being dead.

Other way to get over with this quest[]

After you talked with the Jarl's Mage and accuse him of Necromancy, he then tells you to come at night. In the day, I ran across the true culprit running to the house where he was performing his rituals. I juste followed him inside, he instantly turned hostile, I killed him, sold him to Jorleif, Quest complete. My two cents... 23:45, February 5, 2013 (UTC) theshade973<at>hotmail.fr


tried talking to jorleif/gaurd/captain lonely gale (?) and zip. Stole key from tova, also negatory. Took amulet, journal/s and "beware the butcher" letter but curio guy and viola still don't have any questy dialogue options. I think the problem is that I've completed dark-brotherhood (and imperial?) but I don't really know. Done the quest before on another account, but at level forty six there's no way I'm reloading an ancient save! 04:05, June 11, 2013 (UTC)

The Brotherhood - Tova dies (apparently this breaks the quest)
Imperial Legion - No problems for me, meaning that you can still do it even if you finished the quest-line.
But there are other causes (sometimes is just unknown)
I assume that you're on console and on on PC? Cos you haven't talked about console commands
Wenny0119 (talk) 04:27, June 11, 2013 (UTC)
Tova only dies if Nilsine shatter sheild is killed in the brotherhood quest line. So, she's still kicking. Tried a few console commands but they didn't seem to have any effect.

The Prerequisites[]

It appears that the prerequisites for this quest are inaccurate. It simply states that you have to visit Windhelm at night. That, however, isn't true. I've started the quest in the middle of the day before. I can't start the quest now, though. I did a new game (to avoid some glitches). I'm a level 11 Khajit, the calendar on my game is ar Morndas, 8:14 PM, 18th of Last Seed, 4E 201, and I have yet to complete Before the Storm. I have reason to believe that the quest will start at any time of day, but only after a certain date. I'm playing on the Xbox 360, so don't just hand me a bunch of console commands to start the quest, please. I just want to confirm what the actual prerequisites for the quest are and to have the correct ones put on the page to avoid any further confusion. In the meantime, I'll be experimenting to see if I can figure them out for myself. ~On the wings of fire and devastation, I return. (talk) 00:18, September 19, 2013 (UTC)

I can't confirm the date to be a requirement, but I have confirmed that Before the Storm must be completed to start the quest. Also, as I stated above, you DO NOT have to visit at night for it to start. ~On the wings of fire and devastation, I return. (talk) 04:13, September 19, 2013 (UTC)

Alright. I've confirmed the prerequisites and they are as follows: Level 10, and Before the Storm completed.

There are no other requirements for the quest to start from what I have seen. Visiting Windhelm at night is not necessary. One can visit Windhelm at any time of the day and the quest can be started. If someone with authority can fix these on the quest's page, I'd be very grateful. Thanks. ~On the wings of fire and devastation, I return. (talk) 21:02, November 17, 2013 (UTC)

I appear to have been incorrect in my above statement. There is at least one other requirement. I'm not entirely certain, but I believe it may be that there is a 5 Quests Completed requirement. Can't this just be checked with the Creation Kit? ~On the wings of fire and devastation, I return. (talk) 18:21, March 24, 2014 (UTC)

Quest will not start[]

Ok I am level 53. Quest will not start no matter what I do. I have completed the brotherhood quest and have completed battle for wind helm. I have found the key to hjerim on the dead body of som1 battle born with a suacide note beside her. I have used the key to gain entry to hjerim and have picked up all notes, books and items and spoken to everyone in the town. I have also tried the fast travelling back and forth. If I go to the steps of the grave yard there is the body of idesa sadri. But no blood trail and no gathering people just walk by saying what's happened here. If I ask to buy the house of the jarl he just says I can't at the moment. The only thing I can seem to do on PC is enter

setgate a7b33 10

And then

Completequest MS11

This completes the quest buys the house and allows u to purchase the furnishings. Only the house is bugged like all the new furniture is just placed over the old and pretty much everywhere I look there is an investigation something. Anyone had any luck yet? I don't wanna play it through again this is my third time as every time I try and complete I get at least one glitch wich means I can't fully complete the game. ~schoolboyerrorsfrombethisda20:34, August 15, 2014 (UTC)~

Updated with new information[]

A trivia fact worth mentioning: Calixto can be seen walking Windheim streets at night and even standing near Candlehearth looking for someone while Wuunferth never leaves his room. That was how I realized that Calixto might have something in common with Butcher and Wuunferth might be innocent. 20:51, November 2, 2014 (UTC)

(Bug solution and SPOILER ALERT)

I've found a solution (at least it worked for me) for the bug (ONLY FOR PC) when you have to catch Calixto at the Stone Quarter, after talking to Wuunferth, where he'll just stand still and be unable to interact with (a message "this person is busy" will appear). 

Let me know if my solution was useful to you, so it can be added as a recommended solution to the Bug List.

There are 2 methods: either killing the woman with the console or with your own hands (the latter will add bounty) or opening the console, selecting Calixto, typing "disable" and then "enable" (without the quotes and without closing the console while doing this) and, when done, close the console. In both situations, it'll be fixed and the quest will continue as usual and you'll have to catch Calixto (and by "catching" I mean killing him). NOTE: By doing the disable/enable method, any extra gear equipped by Calixto due to mods (such as cloaks or hoods) will be removed and he'll appear with his vanilla clothes (not like it matters, anyway, because you'll end up killing him).

KongarStonebreaker (talk) 19:00, December 14, 2014 (UTC)Kongar Stonebreaker.

Susanna murdered after Blood on the Ice[]

So here's my weird incident.

I started this quest by sneaking into Hjerim and finding the relevant journals etc. Went around, talked to folks, talked to Wuunferth and accused (actually, killed) the Butcher (real named disclosed) before his first (or was it third?) assault. With the Butcher dead (and the Strange Amulet forever imprinted on my inventory) I completed the quest (both of them, actually). So went afar, travelled across Skyrim, and soon forgot about this bloody mess.

A month later, I came back to Windhelm, for some shady business (and none of your business), only to find Susanna lying dead in cemetery. Aye, stone cold, gaps and claw marks on her body, and the occasional "large diagonal cut from left shoulder..." And that's when my eyes went like o.O Say now, I asked myself, WHO could possibly kill that sorry @$$ wench-- oops, I meant, that flirty (morally dubious) barmaid. I could come up with dozens of answers (from vampires to skeever masterminds to plain cheated would-be love interests) but seriously, wasn't she supposed to die at the hands of the Butcher?

I know, it's not a bug or something, it was just weird to happen on such a thing. And I thought I should share with you. 15:27, January 26, 2015 (UTC) zontoxira

That probably was a bug of some kind. Maybe Calixto came back from the dead and killed her. I keep having a similar incident with Skjor coming back from the dead. This is my second straight character where he comes back from the dead. He dies in one of the quests for the Companions when he tries to take out the entire Silver Hand by himself. He keeps reappearing in Whiterun at Jorrvaskr like everything is normal. Also, with my previous (a dunmer) character, I got sick of listening to Njorda Stonearm belittle me, so I took her to Boethiah's Shrine and sacrificed her on the altar there. She also reappeared in Whiterun like nothing happened. They make the same stupid comments over and over. So, just throwing that out there. It's probably a bug caused by entering Hjerim without getting the quest from the guard who initially investigates the crime scene. My bug was most likely caused by having Wuunferth accused/arrested without getting the Strange Amulet appraised or making an accusation directly. Shark19 (talk) 06:43, June 22, 2015 (UTC) Shark19 (talk) 06:45, June 22, 2015 (UTC)

Viola Bug[]

Ok so I followed Viola on Hjerim but once she enters the house she freezes in one place and wont move.Any tips on how I can solve this bug??

Quest Accidentally "Completed" After Having Wuunferth Arrested But Without Taking Strange Amulet to Calixto[]

I began the quest when I walked by a guard and the witnesses (including Calixto) standing around gauking at the body of Susanna the Wicked, but after completing the Liberate Falkreath Hold segment of the Liberation of Skyrim quest. Ulfric told me after I retook Falkreath with Serana, Ralof, and other Stormcloak soldiers from the Empire that he would be honored to have me as a resident in Windhelm, yada yada yada. I hadn't even started Blood on the Ice yet, so I talked to Jorleif, and bought Hjerim. It didn't give me the option to purchase any accessories, clean up the murderer's mess, etc, probably because the quest involves the house directly. So I started the quest, and I found the Strange Amulet. You're either supposed to take it to Wuunferth or Calixto to have it appraised, but the objective given is to take it to Calixto. I ran into Viola Giordano, and showed it to her. The dialogue came up in said conversation with her some how or other that "It looks like the court mage has been experimenting" so she said "you must report this to Jorleif right away" and I did. All this without having so much as talking to or even encountering Wuunferth or Calixto to have the Strange Amulet appraised or accuse anyone. So Jorleif had Wuunferth arrested, and the quest was "completed" with the wrong guy in jail permanently. Honestly, I couldn't care less, really, about the Necromancer's Amulet. I just hate having Wuunferth, who is innocent, stuck in jail permanently, while the real killer got away with his crimes and is still on the streets. I've since talked to Jorleif, Wuunferth, Calixto, Viola, and several guards. No one says anything about it, except for something like "the streets of Windhelm are safer now, thanks to you" while I know that's not the case. I suppose I could load a previous save, and do it over, but that's a lot of stuff to do over again. I saw something on here about "reopening the case". Has anyone else done this quest in the same sequence as I mentioned with leaving out those two steps (without having the Strange Amulet appraised and without accusing Wuunferth directly)? Shark19 (talk) 06:18, June 22, 2015 (UTC)

Maybe modify the Jack the Ripper statement?[]

Before Jack the Ripper, there was someone called the Servant Girl Annihilator of Austin, who was thought to be a chef named Maurice. He would cut up girls at night with precision. Jack the Ripper was also thought to be a chef named Maurice (only a few years after the Austin murderer, who mysteriously disappeared, and was tracked to Whitechapel), so maybe something of this should be on the page. It's pretty significant seeing as Calixto is called the Butcher, and this was a chef.

CarbonJM (talk) 04:21, February 5, 2016 (UTC)

Blood on the ice[]

ok i had accidentally went to the steward and put the mage in jail I want to fix it how

Walkthrough #10 is wrong[]

Walkthrough reads: "The Strange Amulet can be shown, and eventually sold, to Calixto. (...) The amulet is needed in order to accuse the court wizard. It may be best to sell it, (...)"

This is misleading and wrong. The future dialogue options are unchanged whether you sell the amulet or not (your character will refer to the amulet as if you still had it in your inventory). Conclusion: You should always sell the amulet to Calixto at this point (#10) to avoid the bug where you can't get rid of it.

I kept the amulet because of the walkthrough, and had to spend a lot of time correcting the mistake and researching the alternatives, not to mention creating a profile at Fandom to write this comment! (-__-) Thor's Horse (talk) 18:16, August 21, 2018 (UTC)

You're free to edit the article as you see fit. —Atvelonis (talk) 22:14, August 28, 2018 (UTC)
Yo. I tried to, but the page was protected. Someone edited #10 right after though, so you're free to delete 'my' segment here on the talkpage. 2A04:2746:730:E00:DCBD:657A:F1CC:A74C 22:28, August 28, 2018 (UTC)
Ah yes, I see. Well thank you for leaving this message here, we probably wouldn't have caught it for a while. I hope to see you editing more in the future. —Atvelonis (talk) 03:42, August 29, 2018 (UTC)

what does this mean?[]


does it mean theres something wrong with the article, well, there is no video on this article. —This unsigned comment is by Mr. hayward (talkcontribs) . Please sign your posts with ~~~~!

In 2016 Wikia restructured their ad layout in order to improve page loading times for readers ("Wiki Modernization"), among other things. By concentrating multiple small ads into one single, highly visible ad, they could decrease the number of external web server calls that each page would have to make, massively improving performance for readers (something like 46% faster).
This, in theory, was an appropriate course of action. However, the videos that they decided to put up in order to draw people's attention were extremely low-quality, containing copyrighted footage, factually incorrect information, and utilizing an informal and unencyclopedic tone. Although they made a very minimal attempt to allow us to submit scripts for videos, they did not listen to any feedback that we provided on the videos, instead forcing them on our pages without a chance for us to alter them. As a result, we designed {{WikiaVideos}} and placed it on every article that contained a "Featured Video" at the top in order to warn users about potential misinformation and to distance ourselves from the process.
As profit-focused as they are, though, Wikia did eventually hear our non-stop barrage of complaints and removed Featured Videos for all logged-in users. The videos still appear if you are logged out, hence why we have kept the templates, but until FV is completely phased out in the near future, the notices will remain up.
Also, as an aside, please try not to edit other people's talk page messages, and remember to sign your own by including four tildes (<code>~~~~</code>) at the end of your message. —Atvelonis (talk) 02:44, December 13, 2019 (UTC)

Can't buy a house[]

User:Atvelonis, according to the article "The quest will then be completed and the Dragonborn will now have the ability to purchase and decorate Hjerim from Jorleif if they did not arrest Wuunferth earlier." but this isn't quite right, the Dragonborn must also complete "The Battle for Fort Sungard" or the Imperial Legion questline. Just completing Blood on the Ice isn't enough. But I can't change it. Sacred Fur Shoes (talk) 00:44, 13 February 2021 (UTC)

Thank you, I don't know how I missed that. I have edited the page in Atvelonis's stead. Ottoman Hold Message Me My Action 03:09:46 February 13, 2021
User:Ottoman Hold, thank you. I was also confused by the trivia "If the Dragonborn purchases and upgrades Hjerim after accusing Wuunferth and completing the quest, Calixto will still retreat to the house". According to Houses (Skyrim), Blood on the Ice must be completed and either the Stormcloaks or Imperial Legion must be sided with. But now I understand that Blood on the Ice doesn't have to be completed, accusing Wuunferth is enough. The confusing bit is that "have the ability to purchase and decorate Hjerim from Jorleif if they did not arrest Wuunferth;" suggested to me that if Wuunferth was arrested you couldn't buy Hjerim, but this is wrong, if you accused Wuunferth you already have the ability to purchase Hjerim. I assume the quest is closed when you accuse Wuunferth but re-opened when the next murder happens? I don't know, after I accused Wuunferth I immediately realized I should've tried talking to him first and reloaded a save. Sacred Fur Shoes (talk) 09:08, 13 February 2021 (UTC)