FANDOM


Possible Glitch.

At the moment there is no way for me to get into Calixto's House of Curiosities without breaking in. I haven't been able to get in no matter the time of day. This prevented me from doing the Blood on Ice quest since I could not give him the amulet. Any confirmation that anyone else has had this glitch so I can add it on the page?

Also when I succesfully unlock the door the game gets stuck at the loading bar whe

41.132.114.144 09:43, December 7, 2011 (UTC)


I have had this glitch too. It used to be open to me, but now it seems like it is forever locked, even when he is awake and at home, at which time he will accuse you of being a trespasser. Just a heads up about the Blood on the Ice Quest though, I was able to find him walking around town, so it can be completed with this bug.

96.234.173.238 22:21, December 10, 2011 (UTC)

I have the same glitch. I am unable to get the amulet identified and haven't found him around town. Where did you end up finding him?

216.165.143.136 17:45, January 28, 2012 (UTC)

I was able to find him just outside his shop; I kept waiting an hour until I saw the door quickly open/close. If you have the quest you will see the arrow no longer points inside, but points to where he is currently.

Two questions:

1. There is obviously a lower level, you can see it through the floor. The only thing I have found as a possible way down is there is a locking/unlocking sound when you sit on the livng room chair. I have had my follower sit there after repetitive clicking on them ("not supposed to be in here") but nothing seems to open. How do I get down there?

2. There is a crate in the attic that only unlocks with a key. Where or when is the key available?

Please post on my blog http://scrollsofskyrim.blogspot.com/ answers if you know any of that info. Thank you.

I've had the same glitch as well. I tried a couple things to fix it, one was waiting to see when he left his place (seems as though he wanders around the city sometime around 9am), and the other was accruing a bounty while waiting in his house to see if paying it off would reset things (it didn't). An interesting side effect however, after waiting too long he attacked myself and Lydia and got beaten into submission, but then he kept attacking us as soon as he recovered. I left, he followed. I quickly cast harmony on him and then I was able to talk to him just fine. Hope this info helps any who also have the problem.24.84.131.65 08:26, February 14, 2012 (UTC)

I have the same problem, and I havent yet started the Blood on the Ice quest. I got an invitation to the museum and went to check it out. I found Calixto just inside the city gate and he offered me a tour, but upon following him to his house, the door was locked and when I broke in he had forgot I just paid him two septims to see his curiosities!

72.128.49.233 17:42, February 28, 2012 (UTC)

I fixed the glitch by simply waiting in front of his door day after day. It opened at 8:00 AM, on Tirdas. Can someone else that has this glitch confirm to me that waiting until Tirdas fixes the glitch? ~Crykov - I spam with knowledge. (talk) 00:36, January 15, 2014 (UTC)

Master-level lock? Edit

Whenever I've gone to Calixto's (on PS3), the lock has always been an Expert-level lock, not a Master-level. Can anyone else confirm this? Sgt. S.S. (talk) 09:00, June 12, 2012 (UTC)



Confirmed. Although I use a 360. I get a expert level lock on 360.

Since completing Blood on the Ice, the lock on Calixto's House of Curiousities is a master level lock - on PS3. 58.96.46.106 05:45, August 15, 2012 (UTC)

Solving the Problem Edit

I always encounter the supposed glitch where Calixto is inside his house when I need to speak to him about the amulet from the Blood on the Ice quest. If you are a member of the theives guild, then this may work for you. I broke into his house, sheild bashed (or weapon bashed) Calixto in the face, ran outside, sheathed my weapon so that he would give up to fight, payed the guard off to ignore my crime, and then turned and talked to Calixto before he went back into his store. It worked the first time I tried it and hopefully will help the rest of you.

Also in answer to the question to how to unlock the upstairs chest, you have to pick-pocket the key from Calixto (also how I easily broke into the shop by bypassing the master lock because I took the key before I started the BOTI quest). Tutor et Vindex (talk) 02:06, October 2, 2012 (UTC)

can anyone help me I finished the blood on ice quest and I want to look at calixtos inventory on what he got for sale but he isn't there I tried leaving and fast traveled to winterhold and traveled back he still isn't there I had to unlock his door and he still isn't there plzzzzzzzzzzzzzzzzzzzz someone help

Community content is available under CC-BY-SA unless otherwise noted.