This spell seems to have no effect at all. All it does for me is make the area around me look kinda blue. I'm about 50m away from closest objective and i see nothing at all.

It does have an effect, although you should be far enough from your objective to see it. You have to hold down the button you have it set as, and look all around you for a path.

I can confirm there's no path drawn at all, i've tried both looking around all the way and zooming out in 3rd person and if just illuminates where i'm standing.

There's a possibility you're too close to your target, or have a target that isn't the type to be led to [One where you have to do some seeking / searching.] It should appear as in the picture on the wiki.

Weird Glitch Edit

I've had a glitch where the blue line is still there and hasn't gone away; I was in the theives guild testing the spell out and now the line is still there whenever I enter the room and it won't go away. Is anyone else seeing the spell linger indefinetly, or is this some sort of a one in a million chance? (By the way, this is on PS3 that this happened, before patch 1.2 but is still there to this day)

I can confirm this in the pc version. In dragonreach

Can confirm this for Windhelm on the Xbox 360 verision. Ocurs when saveing when using the spell, I have been testing this and now Windhelm just covered in blue lines.

Is there any point in dual casting this?Edit

I'm wondering if I should bother dual casting this or not. I don't see any difference between the strength of the single cast and the dual cast.

It increases the length of the trail by dual-casting it. Given you sacrifice more mana per second. TENSUKI (talk) 20:31, January 5, 2012 (UTC)

Graphics Settings Edit

Before starting a game, press options button and then select advanced. Choose Median or High in Radial Blur Quality. Even though other settings are set to the lowest one. The line of Clairvoyance cound be seem.

Good luck if you want this spell to take you to Orphan Rock. Edit

The clarvoyance spell seems to think that Orphan Rock is floating in mid-air somewhere between Helgen and its actual location. Definitely not the first time something like this has happened. They really need to work out the bugs in this spell. PS3, haven't updated in a while, pointless to see if the update will fix it since I already got there on my own. --Gothzilla the Annihilator (talk) 15:49, January 21, 2012 (UTC)

Worst Spell Edit

It rarely works. Usually, you only need it when the map markers aren't going to do the job for you, but the spell leads you back the way you came or into a wall or something stupid. I tried to use it to locate the pages in the Soul Cairn, but it just led me to the entrance stairway. I made sure the only quest I had active was that one, so something is very wrong with the function of this spell. Monkey-_ 11:34, May 24, 2013 (UTC)