FANDOM


I think that it would be much better if somebody could just write down what is in the strategy guide for this particular quest. I really hate all of these Shrine Wikis that have nothing on them but just a general direction that you are supposed to follow to get there.

No can do. That violates (or, should at least) copyright law.

Mora's Soul Trap not working Edit

After getting seven of the ten souls I needed, Mora's Soul Trap spell is no longer working. Anybody else have this same glitch? The purple illumination around the enemy that I cast it on fades really fast, and no matter how quickly I kill, I never capture any souls. I still need Orc, Argonian, and Nord souls. Can anybody shed some light on this? --Wes R 12:56, 24 April 2006 (CDT)

Same thing happening here, but after 3 souls. --Guest 11:51, 27 May 2006

According to another wiki, this is a common problem. I'm trying to find a workaround (I found a mod that was supposed to fix it, but the link was dead), and if I manage one, I'll post it here. —This unsigned comment is by 72.38.248.159 (talkcontribs) . Please sign your posts with ~~~~!
Found a link to it that works (for now). An unofficial mod to fix this bug can be found here: [1]. —This unsigned comment is by 72.38.248.159 (talkcontribs) . Please sign your posts with ~~~~!

Got the same problem, I have about 5 souls, and it looks like I'm screwed at this point. I've run across so many bugs with this game in the last few months, it bothers me that companies even release something that only works HALFway..... —This unsigned comment is by Zarozinia (talkcontribs) . Please sign your posts with ~~~~!

Beothia's chosen Edit

I removed this entry from the list of possible "soul sources", since Hermaeus Mora's quest has to be done after all other Daedric quests. Alchemica 03:19, 31 December 2006 (CST)

Mora's soul trap stopped working: 360 version. Edit

I only have 4 souls and it stopped working. The people I cast it at stay purple for a few seconds then it goes away. Even if I kill them while they are purple, it still doesn't capture their soul. Can't mod because I'm playing on the 360. Any suggestions? —This unsigned comment is by DoomPenguin (talkcontribs) 15:30, June 8, 2007. Please sign your posts with ~~~~!

I've never done the quest myself, but here are some suggestions:
  1. Do you have enough Black Soul Gems to capture NPC souls?
  2. Try using another soul trap spell.
  3. Lastly, reload an old save before starting the quest and try again. --theSpectator talk 21:54, 8 June 2007 (CDT)
EDIT: And what exactly "stopped working"? Your spell? The gems? Your character? --theSpectator talk 21:55, 8 June 2007 (CDT)

As far as I can tell it is the spell that stopped working. When I cast it at a character, they will glow purple for around 5 seconds. Then the purple glow goes away. Even if I kill the NPC during those 5 seconds, no soul is captured. —This unsigned comment is by DoomPenguin (talkcontribs) 19:12, June 12, 2007. Please sign your posts with ~~~~!

I've responded to an e-mail by DoomPenguin regarding this issue and I'll post it here, in case other 360 users have the same issue. Unfortunately there's not much else to do other than reload an old save or move on from the quest.
"Well, I've never done the quest before so I don't know. However, according to the quest article (which I didn't read before replying to you), it says that you must use Mora's spell and special soul gem to capture the soul. So I don't think another black soul gem or other soul trap spell will work.
"Also, reading the other comments in the talk page, apparently your problem has been a problem for other users too. I'm not sure how else to approach this problem except either 1) reloading an older save before you started the Mora shrine quest, or 2) you're kinda stuck for now."
--theSpectator talk 15:41, 13 June 2007 (CDT)


Apparently you don't have to be level 20 for this quest or have the rest of the daedric quests done... I was sleeping in my Leyawin house to reach level 18 when someone approached saying Mora requested me... I still hadn't done Boethia's quest... Also, I kind of had that same problem with the spell where sometime it wouldn't capture the soul... I just moved on to another victim and eventually it worked... I just had to make sure I didn't get a bounty for killing each time... Orban Sirgen (talk) 15:41, April 11, 2011 (UTC)

oghma pictureEdit

the picture for the oghma infinium on this page is the one for skyrim. it should be a picture of the oghma infinium from oblivion. someone fix this.

Community content is available under CC-BY-SA unless otherwise noted.