FANDOM


"Cannot be obtained if the Dragonborn kills Logrolf the Willful rather than freeing him and allowing him to go to Markarth."

I killed Logrolf while he was in the cage and got the mace.

Did you get the rusty mace? or the improved clean mace?Neguy71inok (talk) 00:32, January 27, 2012 (UTC)

I can actually confirm, I killed him and got the real, improved version HaLo2FrEeEk (talk) 00:34, January 27, 2012 (UTC)

list this in the bug section, not supposed to be able to do that, I think this was already mention in The House of Horrors quest. Neguy71inok (talk) 00:38, January 27, 2012 (UTC)

On Person?

Do you need to have all 15 on you at once, or do you have to have owned them at one point. I sold some of my artifacts. Bioniclepluslotr</span> 03:06, April 30, 2012 (UTC)

That's fine. The latter is true. – Moozipan Cheese(talk page) 23:18, May 9, 2012 (UTC)

Having Trouble

Terribly sorry, but I will be adding to those that have experienced difficulty with this achievement.

My counter says I have completed 15 Daedric quests. I acquired Azura's Star, Dawnbreaker, the Ebony Blade, the Ebony Mail, the Mace of Molag Bal, the Masque of Clavicus Vile, Mehrunes' Razor, the Oghma Infinium, the Ring of Namira, the Sanguine Rose, Saviour's Hide, Spellbreaker, Volendrung, and the Wabbajack.

I also acquired the Skeleton Key, but I'm aware that it doesn't count towards the achievement. What I want to know, I guess, is: Did I screw myself over by letting Erandur live during Waking Nightmare? It was the first or second Daedric quest I did, so there's no going back now. Am I just experiencing a glitch, or what? I really don't want to have to go through all the quests again just because of that.

Cheers.

Sláinte mhaith! - Hobbes (Talk) 05:19, June 30, 2012 (UTC)


Looks like that is probably the case, check my new thread. I think they fixed the ill met exploit. SlainSeraph (talk) 09:49, August 8, 2012 (UTC)

Extra Artifact Exploit fixed?

Template:360 I got what should have been my 15th artifact after using the Ill Met By Moonlight exploit, but no achievement. This forced me to go get a 16th artifact to get the achievement (which honestly I was going to do anyway even if it had unlocked). I found a guy on an achievement guide site saying he had to do the same, timestamp of Aug. 1, 2012. Maybe 1.6 had a fixed for that stealthed in? Or possibly part of Dawnguard? SlainSeraph (talk) 09:47, August 8, 2012 (UTC)

Template:360 The exploit isn't fixed, Dawnstar bugged one of the other Daedric artiufacts as counting toward this achievement. I did Ill met by Moonlight last, and only by getting both the ring and the hide did the achievement unlock. In fact, I had to redo Ill Met as I only took the hide the first time. Taking the ring first and then the hide got me the cheevo. 174.103.156.253 19:02, August 26, 2012 (UTC)

Expanded

Is it confirmed that this achievement is bugged in any way? I have 15 qualifying artefacts but haven't been able to unlock the acheivement. I have them all on one character, and have even tried having all 15 on me at once (as I haven't yet read the book).

I've searched the web and it seems a lot of people are having this problem although a lot are confused about the right artefacts. Nonetheless loots of people have 15 correct ones and don't have the acheivement. It also seems a more common problem since the Dawnguard DLC.

Any thoughts?

Violet 19:39, 2nd Oct 2012 (BST)

I'm on my fifth character and all five have completed the 15 Daedric Quests. Still no Oblivion Walker Achievement per the Achievements area of XBox Live. Finally on number five I killed Erandur to get the Skull of Corruption in my possession. I have even had the 15 items on my character at the same time. Having Hircine's Ring instead of Survivors Hide and placing the Skeleton Key with Namira. Yes, I have both Dawnguard and Hearthfire installed.

Is it a bug? Don't know but I really would like to acquire my 65th achievement.

Bartlmay (talk) 01:18, November 4, 2012 (UTC)

I'm starting to believe that having both Hircine's Ring and Savior's Hide doesn't count towards having two Daedric artifacts anymore. I purposely left the quest "Walking Nightmare" for the last quest to do, just to see if having the two artifacts from the Hircine quest would count...but alas it didn't. I had 15 Daedric artifacts minus The Skull of Corruption, so my achievement should have popped up then, but it didn't. So, then I went on and did the Walking Nightmare quest to get the Skull of Corruption, this time after killing Erandur and taking the Skull of Corruption, my Oblivion Walker achievement popped up.

I don't know what's going on with people missing this achievement otherwise, unless they took the Rufel Axe instead of the Mask of Clavicus Vile, I just don't see how it can be missed. Maybe the addition of Dawnguard did mess it up. I'm just glad that I don't have to do that stupid quest ever again. 68.227.51.216 01:36, November 4, 2012 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.