FANDOM


Are the items in the chest unique?

i got +50 stam dwarf boots (and some other junk) in 3

WitE (talk) 03:41, November 18, 2011 (UTC)

I cant be sure but it feels like the treasure wont spawn unless u have the map as I cant find them where they should be...

WitE (talk) 13:37, November 18, 2011 (UTC)

the loot is level based as I have compared with friends and I am level 32 and have 93 smithing and got ebony ingot and my friend level 20 with level 70 smithing got malachite ingot, and you need to have the map to get the treasure, although I have treasure map X and it wont show up for me.


where the hell are these treasures? I have the maps but there not showing up especially map 3

Glitches Edit

I think there's a glitch where treasures won't show up even with the map in your inventory. I attempted to fix it by traveling to another area, depositing the map, then picking it up again, to see if that corrected the problem, but it still persists. My problem is with Map 2. I've compared with online videos as to its location, and it's not there despite having the map. (Xbox 360) *Edit* I've discovered, according to some, that the 1.02 patch is the cause of treasure maps not enabling the chests.

The 1.2 update indeed broke treasure maps, but the 1.3.7.0 update fixed them. Update your game - Bethesda probably won't document fixes to regressions in their release notes if they're not already well known issues (e.g. dragons flying backwards).Kastagir (talk) 02:14, December 13, 2011 (UTC)
^Actually, my game's been updated, and it's still having the same problem (with map 8). I play on 360.

Fort Neugrad treasure map same issue on PS3 Edit

I got the map, held on to it, went right to the spot, nothing, fast travel, PS3 restart, revisited several game days later, dropped map and picked it up again, went back to the chest that held the map and put the map back in it, etc.. etc.. I haven't even attempt to locate any of the others I have yet, don't want the frustration factor right now. Neguy71inok (talk) 09:15, December 5, 2011 (UTC)

Map IV bugged? Edit

Treasure for Map IV seems to be bugged (X360). Have the map but no treasure. :(


207.237.243.147 05:48, December 29, 2011 (UTC)

Treasure map x is actually found on an island in the middle of the lake by a flowering tree at the base of the waterfall.

I have the 1.4 update, and have had several maps from game release, playing the same char. Chests do not show up for me. ANyone know of a fix? on PS3

Treasure Map V bug?Edit

I recently obtained Treasure Map V, but when I open it I receive the miscellaneous objective "Find Red Eagle's Sword", even though I did that quest a long time ago. I tried reloading an old save, but got the same result. I play on PC and have the Unofficial Skyrim Patch installed. Anyone else have this problem? 71.185.239.164 00:51, June 5, 2014 (UTC)

That quest does reappear repeatedly. However, I'm not aware of it recuring when reading this treasure map. If can recur any time you read the book. Cubears (talk) 04:38, June 5, 2014 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.