FANDOM


  • I really don't know how to start the Shahvee's Amulet quest, I've tried a lot of solutions like completing Amren's family sword quest and advanced the main story to the Thalmor embassy quest but it hasn't done anything, it only comes up with one dialogue option, so should I go further into the main quest or try something else.

    P.S. I have also completed the Civil War quest and sided with the imperials.

      Loading editor
    • A reason could be that you have cleared the location of the quest. Try and wait for I think at least 30 in game days for the location to respawn. The same thing happened to me once with a different quest and I just waited for a while and then I got the option to start the quest.

        Loading editor
    • I have tried waitig well over 30 in game days but i never got the option for the quest

        Loading editor
    • There are a few other quests for random NPC's that cannot be active at the same time. One is Roggi's ancestral shield. The quests that fall under THIS category are the ones that are not related to acquiring fame/"being known by my people in the hold" and are just random people asking for items to be found.

      http://en.uesp.net/wiki/Skyrim:Dungeon_Delving_(Caves)#Radiant_Options

      Here is the list of the quests that only 1 may be active at a time.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.