FANDOM


  • As the title suggests, when I speak to Delphine while I have ANY follower following me and tell her to induct my follower into the blades and I tell her I'm sure she says that she will give them the oath..... followed by nothing. She just goes back to what ever she was doing and my follower is not dismissed no matter how many times I select the option.

    Notable things:

    I have not yet reached the stage where they require you to kill Paarthurnax in order for you to further interact with them.

    The dialog option "I've brought someone to induct into the blades" only appears during her first lines when you initiate dialog and then disappears once she finishes what she is saying. I can only get it to reappear if exit the dialog then wait roughly 10 seconds and speak to her again then I have the option (but only while she is speaking). I can select the option and it appears as if everything is normal but after I confirm I want the induction she says she'll give the oath and then nothing happens. I have tried this with several housecarls and many followers all of which fail to leave my service. (She also never says the oath)

    I have tried disabling every one of my mods and it still does not fix this issue. I am unsure if it is possible to fix this or if there are any console codes/mods that will allow me to manually recruit a follower into the blades without having to speak to Delphine but I see that as the only solution other than starting a new game with no mods enabled.

      Loading editor
    • i think ive also encountered this with serene(?, the vampire girl in Dawnguard?) 

        Loading editor
    • Serana cannot join the blades. As for the OP's problem, I don't know. You might be able to solve the problem with addfaction console commands, but I'm not too experienced in that area.

        Loading editor
    • SynikaI
      SynikaI removed this reply because:
      Was a comment by me, mistakenly posted while not logged in.
      19:20, June 7, 2014
      This reply has been removed
    • I have found a solution! They will act like Blades and dress like blades and move into the Sky Haven Temple. You can do this by:

      1. Open the console while the desired NPC you wish to recruit into the blades is currently your follower and click them to select their RefID.

      2. Type into the console "SetConsoleScopeQuest FreeformSkyhavenTempleA" (Without the quotations, of course)

      3. Then type "ForceRefinToAlias blade01". (Or replace 01 with 02 or 03 depending on what the next available blade slot is. You can check this by typing "sqv FreeFormSkyHavenTempleA")

      After that they should move their home to Sky Haven Temple and will do so once you dismiss them from being your current follower. 

      To get a second person into the blades follow these steps but FIRST you will need to cause the game to initiate the next stage. Check which stage the quest is currently in by typing "Player.sqs FreeFormSkyHavenTempleA". If you are on stage 10 then it is still waiting for you to recruit a follower to the blades. If you have and are now wanting a second you must type "setstage FreeFormSkyHavenTempleA 20" to cause her to move onto the next follower and replace 20 with 30 once you have the first two.

      Once you have all three needed change out the 30 with a 40 and it will point you to talk to Esbern about dragon lairs to start the repeatable quest "Dragon Hunting". 

      That's it! I hope this solved the problem for anyone else who has this pain in the ass.

        Loading editor
    • SynikaI, thank you very much!

        Loading editor
    • I did all this and it worked 100% but the only issue is, if you hire someone to be your follower and then go and do all the console commands, after they all work and i go to recruit one of the mercenaries i made become a blade, i have to hire them (500) gold. is there a fix to this? Seems like my fellow blade has to be hired to come battle dragons with me. Annoying cause doesn't follow law.

        Loading editor
    • If you have the Multiple Followers mod running then it will keep the quest from working properly. Just make sure the mod doesn't load in your data files when you do the quest. Also, make sure you don't have multiple followers following you on the save that you load when you open your game again or the followers won't follow you or something glitchy like that, it just won't work proplerly.

        Loading editor
    • Thank you sooooooooooooooo much

        Loading editor
    • The console command dont work

        Loading editor
    • Awesome, it took a little time for me to get it right, but the arrow over Delphines head finally went away.  I have a bug where I cannot enter breezehome, so I finally cloned Lydia to recruit her.  Since the original is probably locked in the house I can't enter in Whiterun, I doubt there will ever be a conflict.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.