FANDOM


  • First off - this is on the Xbox 360, ultimate edition of the game with preinstalled DLCs.


    That being said, I'm having major issues while building my homesteads.  My second homestead won't build all things it's supposed to.  For example, say on the carpenter's workbench, I select it to build 3 barrels and two chests.  Only 1 barrel and 1 chest will appear!  I can't reselect them either because the option to build them disapears from the carpenter's worbench.  I've tried waiting with the table menu still up, sleeping, entering and reentering the homestead....  Nothing works.  I've even reloaded previous saves and tried again.


    Any help for this?

      Loading editor
    • Only reloading and trying again like you have done maybe try leaving the area for at least ten days before trying again or asking your Steward to decorate (that can take awhile), once an item is build though if its glitched or not the option will be gone from the bench theres no adding and removing things. Hearthfire is sadly often very glitchy and has no official patch.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.