FANDOM


  • This bug was annoying me to no end, and after a few days, or weeks, of searching (I didn't want to use a mod) I found the following steps. They worked perfectly and I have even placed a new, different armor set (bugged: Ebony, new: Glass) and found no problems whatsoever.

    The fix is listed as being for Xbox but it worked for me on PC - 1.9.32.0.8 + Hearthfire DLC. My house is Lakeside Manor.

    The piece of equipment that was bugged were only the boots so I followed the steps with only those, as specified.

    Fix source.

    Verbatim copy just in case the link becomes unavailable.

    I've found a solid fix for this, that has repeatedly worked to stop my mannequin from duping. It's almost the reverse of what you have to do to start the glitch. I have found some small details to watch out for along the way. Let me start by saying that I have only tried this in Riften at Honeyside, and on the PS3. Hopefully this works for you Xbox'ers out there. This is what you do....

    1) Put 2 of each item that you have been duping into the mannequin's inventory, nothing else. Also, make sure you don't have any more than 4 of each in your own inventory.

    2) Leave and re-enter, making sure that when you leave the house, the loading screen shows an image instead of just a black, smoky screen. This ensures that the house (im)properly reloads.

    3) Activate the mannequin, and remove one of each item from it's inventory. Without exiting the menu, go to your items and put each one back. WARNING: If you have 6 or more items in your own inventory at this time, it will ask you how many you want to place, and this will cause failure. This is why you can't have more than 4 to begin with.

    4) Leave and re-enter, again, making sure that the loading screen shows an image when you leave. NOTE: This is why I like the Riften house, as it's easy to remember which door you went through last, and you can just use the other one.

    5) Activate the mannequin, and remove all the items from it's inventory, leaving it naked.

    6) Leave and re-enter one last time. Again, be sure it reloads the right way. When you go to your mannequin it should still be naked, and will have stopped duping items.

    You can now use it as normal, or you can start the glitch again with a new set of items. I've started and stopped this process a total of 5 times as of this post with no lingering glitches. Hope this works as well for the rest of you as it did for me.

    Extra Notes - I haven't tried to fix the glitch while having non-glitching items still in the mannequins inventory, nor have I tried it with more than 2 of each item in its inventory. I know for sure that if it asks 'how many' to store, that it will cause the fix to not work, or if you don't get the proper loading screen after removing all the items from the mannequin. There may be more details that I haven't tested that will cause failure, and there may be steps that can be shortened or skipped. Once I found what worked consistently, I didn't care to test it further. Feel free to test it on your own, and please share if you find anything more out.

    I think it more than deserves going into the article, I just don't know the proper procedure to go about it (I assume other people would have to verify it, etc)

    Cheers!

      Loading editor
    • Works perfectly!! Thank you so much. I'm using it on mannequins in a mod home on the PS4 special edition and it worked great. Now I no longer have a whole Dawnguard Battalion in my basement.

        Loading editor
    • Super necro but just wanted to confirm this method works like a charm on PS4 Pro SE. Only thing is sometimes the game refuses to give you a real loading screen and if that occurs either do a hard save or a quick save and reload. Thanks for this!

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.