FANDOM


  • Hi. Here is a quick guide on how to fix this seemingly annoying bug. -PLEASE NOTE THIS ONLY WORKS ON PC (SORRY PS3&XBOX360 USERS D: )

    (quick note: skip to the SECOND method if you're looking for the stuck misc quest involving greta and the amulet of talos)

    You must visit Solitude and find the child named Svari - She will ask you to speak to her mother Greta to convice her to go back to the Talos temple. 

    When you speak to Greta she will want you to collect the amulet of talos off of the body of Roggvir and return it to her. 

    Now take note of this - The reason your amulet of talos(s) are marked as quest items is because when you first visited solitude you looted the body of Roggvir and took his amulet prior to starting the quest (Roggvir was the guy being executed). Doing so causes the glitch.

    Now there is two ways to go around fixing this.

    The first way (NOT RECOMMENDED) involes just straight up handing her the amulet of talos that is stuck in your inventory - this will make your talos amulets non quest items again allowing for any others you have stored to be dropped. She will offer a reward however you will not get this reward, nor will an amulet dissapear from your inventory. The problem with this method is it actually creates another equally annoying glitch though it resolves the quest item one. I recommend doing the second way (BELOW)

    The reason I recommend doing the method below is because if you do the one above, you have a permanently stuck misc quest saying something along the lines of "Return Roggvirs amulet of talos to Greta". As you could imagine, this would be really annoying for those aiming to totally clear our their quest log when aiming for a full completion. Anyway, I'll stop rambling and you can carefully follow my instructions below.

    THE SECOND WAY:

    Revert to a save where you haven't spoken to Greta but have spoken to the child (it doesnt matter if it's before you spoke to the child).

    Open Console and type "player.drop 000CC846 1" (This drops your amulet of talos forcefully)

    If you have more than one Amulet of Talos in your inventory then change the number "1" above to the number of amulets you have. 

    Proceed to talk to Greta and say you will retrieve the Amulet from Roggvir's body.

    After talking, you will notice that a quest marker appears on one of the amulet of Talos's that you dropped. Pick it up and it will complete the objective as if you looted it off of Roggvirs body and return it to Greta. She will thank you and walk away without giving a reward HOWEVER you will not have the permanently visible Misc quest meaning you are completely free of any bugs related to this!

    Hope this helped guys,

    flonk28.

      Loading editor
    • Thank you for your solution. However, I seem to have a bit of a problem with your solution. I dropped the amulets outside and now they disappeared. I have no save file that was reasonable close to before that happening and I can't get the right amulet of Talos back, when I try movetoqt SolitudeFreeform03 it just teleports me below the ground, still no amulet. Maybe some NPC picked it up or something. Does anyone have a solution to this problem?

        Loading editor
    • thanks flonk This worked great. Made sure to drop em in the house, then spoke with everyone and ti worked great :)

        Loading editor
    • After talking to Svari and Greta, I fixed it by typing in the console "setstage solitudefreeform03 30".

      After that command, the log and marker updated to the stage where I had to give Greta the amulet. I gave her the amulet, and the quest got completed and out of the active quests.

        Loading editor
    • I did like this and it worked.

      Save before talk to Greta go to where Rogvir body was and is no more because you loot it before talk with her doughter open console type "player.drop 000CC846 1" i had 2 so i dropped them both then after i went to Greta and talked, then i went back to where i dropped them at the execution place and have took one from ground and gave it to Task Completed i went and took the second Amulet from ground.

      For some reason i still have the Amulet it was not given to Greata but this is fine for me at least no more stuck with this task and non removable Amulet.

        Loading editor
    • THIS WORKED LIKE A CHARM!! Thank you!

        Loading editor
    • Willhelm555 wrote:
      thanks flonk This worked great. Made sure to drop em in the house, then spoke with everyone and ti worked great :)

      I completely agree with this man. I tried to drop them outside the house but they didn't drop at all. When i tried it in the house the amulets dropped and i completed the quest.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
*Disclosure: Some of the links above are affiliate links, meaning, at no additional cost to you, Fandom will earn a commission if you click through and make a purchase. Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+