FANDOM


  • I bought every add-on for Skyrim a few years back, and they worked fine (PS3). I stopped playing for awhile, and had the urge to play it again recently. Unfortunately, whenever I'm nearing the end of the Dawnguard questline it seems to crash. I even had to make a whole new character just cuz I couldn't go 5 minutes without a crash, and when I played through the questline again, it's still crashing. It's frustrating me to no end, and I tried just about everything except formatting my PS3, which will be a last resort. I tried loading an earlier save, rebuilding my database, turning off autosave, dusted off my PS3, and putting a fan next to it. While they did improve framerate issues, it did little about the crashing issues. I would usually expect these issues at around 13-165 MB, but now it's having issues at around 8 MB. I'm saving up for my own PC so I wouldn't have to worry about these problems, but until then looks like I'm stuck with the PS3

      Loading editor
    • P.S. It's only happening on my profile. My brother can play it on his profile just fine, and still isn't experiencing any game-breaking issues at around 10 MB.

        Loading editor
    • I have a xbox 360 and it is working fine for me. Maybe it could be a bug or glitch. Check what your brother has done and then compare it to yours so that this way you maybe able to see whether there the choices you have made may have caused a glitch.

      PS this is just a guess see whether it is right.

      From, Pod

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.